Wifi connection problems

so i moved my imp to a different wifi network and am now having problems connecting.  The router shows that the Imp has been assigned an IP address so I’m pretty sure all is well with the network settings.  The Imp is in a loop where it blinks green at medium speed (connected?) about 3 times then red fast about 12 times (connection lost?).  I tried fiddling around with various firewall settings without success.  Not sure what to do next so any suggestions appreciated.


hey don are you still having issues with this?

I occasionally observe the same phenomenon. I believe you have an error in your squirrel code somewhere.

I moved everything back to the original network and it connects fine so I’m assuming there is an issue with my home network. If I figure it out I’ll post an update.

jsffanverizon: I haven’t made any changes to the default code, I didn’t think you could change the code if you weren’t connected to a network.


I’m having the same problem. I believe this was also referenced here [136] with a video, with the exception that I’m using factory firmware (as it sounds like you are).

I tried using the “Update Imp Firmware” from WinBlink; while it flashed the imp successfully, it still does the green/green/green/redredredredredred blink like in the video in 136.

It sounds to me like your squirrel code couldn’t compile and run. Try changing the code to one of the default on the planner, removing and reinserting the card, deleting your imp from the planner, and various combinations of the above (I don’t remember exactly what worked)

Also try looking through this thread: http://forums.electricimp.com/discussion/203/imp-firmware-not-updating#Item_13. I had some firmware issues myself that eventually were sorted out using the same methods.

The “green blinks (connected) - followed by red blinks” pattern most often occurs due to a runtime error in your squirrel code. While planner won’t let you send squirrel code with compile errors to an imp, and will give you immediate feedback that you have compile errors, code that causes a runtime error will go to the imp. The imp will run this code, and the imp will crash and blink red.

To track down this kind of error, it’s often very helpful to comment out your unproven code so that you can recover to a known-good state, then add your code back in bit-by-bit (not necessarily line-by-line, but functional block by functional block), including server.log(“various useful debug messages here”) lines to function as your break points.

One possible cause for this error (I just encountered the codes, and then realised the probable cause):

a password change on your imp account will also result in this blink pattern.

I have got the same problem, can someone help me.

I first had my Imp working but there were problems with my wifi, after they were solved my Imp could not connect anymore. Same problem 3 times green / 12 times red.

Reset wifi settings etc, even deleted the imp from the planner :frowning:

@michel: looking at your logs, your ATSHA read is failing, implying either a bad connection on pin 6 or a dead chip. Do you have another board you can plug into?

Thanx for the reply,

No i don’t have a spare board :frowning:
But i looked closely to the board and i think i see the problem.
(uploaded picture).

That doesn’t seam good to me, something missing!!!

I just looked at the eagle files for the board and the broken part is the ATSHA

So i should buy a new april board i guess.

Yeah, that looks like the part is damaged physically. If you’re in the USA and send your address to dev-team@, we can mail you another ATSHA chip to repair your board if you’re ok with doing the soldering work…

I don’t live in the USA, so i ordered a new board.
Hope to get back online soon.

Thanx for the help.

For anyone else having problems getting your Imp connected, for me uninstalling and reinstalling the Imp application on iOS solved the problem when moving from one network to another. It happened both when I moved to a new network, and when I moved back to the original one.