Verifying firmware update


I just bougth my first electric imp and the breakout board from sparkfun.

-I have commissioned my IMP. The router finds it and I can ping it.
-The last 24 hours the green light blinks “Short green, off, Long green, off”, but nothing happens. (I cant find in in impees or in planner)
Is it verifying firmware update? how long time does it take? Is it another problem? How can i solve the problem?


I also had that situation with one of my imps once. It was stuck in this state for more than 3 minutes, after which I removed power and restarted it. The imp started again with the short green, long green blinks, but after a short while (20 seconds or so) tried to reconnect (amber, red blinks) and then was connected (slow green blinks).

@magnusrt if you have an old-ish imp, and a wifi gateway that has a buggy DNS relay, then you’ll see this behavior - stuck forever in verifying.

Two solutions:

  1. Disable DNS relay on your router, reboot it and retry
  2. Blink it up on someone else’s WiFi, wait until it updates, then you’ll be fine from then onwards.

Mine was stuck blinking green normally. But nothing in Log window. Clicking run didn’t help. No online or offline message. Waited 8 hours, had to power off.

Blinking green normally means it’s connected to the server, not attempting an update. Remember the imp’s appearance in the planner is based on the ID chip on the device it’s plugged into, not the imp itself - are you sure you were looking in the right edit window?

I have disabled dns relay, blinked up on 2 different routers, disconnected it several times and waited alot.

its still blinking, and impees says “You have no impees. You should make some.” nothing under planner

If i disconnect my router the imp continues to blink… Strange

Looking in the logs, your imp has connected many times to the server, and every time it’s been told to go and fetch an upgrade - but it’s never contacted the upgrade server, which is the symptom of a DNS relay issue and an old release (before the workaround went in).

You’d likely see it go red, then green briefly, then back to red, then green short-long. When it’s in the fetching upgrade mode it’s not going to be looking for wifi disassociates, which is why it continues to blink green.

What routers are you using?

I used Dlink DIR 635 and 655.
The 3. router fix it! dont remember the brand


Yeah, older dlink routers had the DNS relay issue. Now the imp is updated with the workaround, you shouldn’t have the issue any more.

I had the same issue. Short and long green forever and no “blank” in planner.
On the D-Link DIR 655 you go to the “Setup” tab, “Network Settings”, “Router Settings” and untick the “Enable DNS Relay” box. Then reset the IMP and watch it update itself.
Unfortunately now everything else on the Internet stops working :slight_smile: so you will have to tick the box again.
Anyway, thanks for the tip!

Hmm, that should not stop anything else working. DNS relay (cache) is just an optimization…

Well, that worked for me too - on a DIR 655. Once I unchecked the "Enable DNS Relay " box then reset the IMP it did the update and showed up on the planner. HOWEVER, I could NOT get anything else on any browsers until going back in and RE-checking the Enable DNS Relay on the DIR 655. Now, all is working well - and the IMP shows up in the planner as it should. Whew. (Only took 4 hours of searching to find this particular thread/fix!)

Once the older imps (which had older software without this DNS relay workaround) are all upgraded, then this won’t be an issue any more… but right now, it can still be a pain I’m afraid :frowning:

The developer edition imps were the first imps made (back in may-july 2012). Later imps, including imp002, don’t have this issue.