Trouble Commissioning

I have a Hannah Rev2 20120314 and 2 imps that are having pairing trouble.  Network is WPA2, B/G, 20Mhz, SSID Broadcasted, Channel 8.  Running the app on a DroidX, 2.3.4.  Tried to use BlinkUp in low light, darkness, touching imp, 1/2/6" from imp, finger over top, etc.  Rebooted phone, checked user/pass and ssid/pass (even tried WPS).  During some pairing attempts it will stop blinking red during the pairing and slightly after and blink fast 3-4 times, and then blick red at the same normal pace after.  During other pairing attempts it will not stop blinking red during pairing.  Any ideas?  Once the iOS app is available, I could try that too.

Generally, if the imp doesn’t stop flashing its LED when the phone screen starts to flash, the issue is with excessive ambient light (it’s not seeing the sync sequence).

If the imp goes dark during the transmission, then blinks red quickly afterwards, this means there was an error detected.

The actual network setup isn’t important at this point as the imp has not received the data yet (you’ll get quick green flashes on success, then the imp will connect to wifi). Sounds like we need to find a DroidX to try - every android phone is different in terms of refresh rate, luminance decay rate, etc - plus some of them drop frames regularly which isn’t good here.

iOS is totally consistent with frame rate and very, very reliable at blink-up. It’s just the app is still in approval :frowning:

I can confirm that even in a darkened room and with fingers over the imp, that the samsung galaxy Y does not work.  It never even sees sync (the amber LED never stops blinking).   I’ve tried about 20 times.   Hurry up Apple!!

I just tried with an HTC Evo 4G (Not the new LTE one but the original Sprint one) and I could not get it to work, the red light kept blinking at the 1hz rate and never stopped. It is a friends phone so I don’t have continual access to it to keep testing, but I did try complete darkness and it didn’t help. Just thought I’d share to help identify phones that might be causing trouble.

We’ve identified a couple of issues with various phones (we also bought a $75 tablet which fails, unlike all the other androids we have in the office which pass consistently).

However, we can’t push the fixes to devices that aren’t online, so that doesn’t help people with initial config. They should make it into release-3 which will be out at the end of next week.

Thanks for everyone’s help; if people are still stuck (ie, no iOS access when the app comes out) after we’ve got it reliable post-upgrade then we’ll see what we can do to swap cards out with ones that have the newer bootrom code in them.

I got up at 4:30am this morning to play with my new Hannah and Imp, ok, ok I’ll get a life;) Tried commission on my home network, Droid X with 2.2.3 - several tries, shading etc. and always - quick red flashes then back to the slow red blinking. So getting an error trying this on my home wifi - so I’m stuck - let me know what work around or options to try. Thank you, 

The new schemes we’re working on won’t help people who can’t get their devices connected initially - there’s no way for us to get the new software to them. If you can, please try and borrow a supported phone to get online, as then we can push new software out to you.

This is awkward, but unavoidable - we tested with all the Android phones pre-launch we had but obviously can’t get full coverage.

Will just add my .02c here that I’m having similar commissioning problems (i.e. a few fast blinks followed by a return to the 1/sec red blink) using a DroidX global, ver 2.3.4 … have tried several of the same things as previous posters.  (App ver 1.0.1).  Will try to borrow an alternate Droid a bit later today.  (All I’ve currently got here is a number iOS devices)!

- Larry

A few people have reported blinkup problems but have in fact got a green flash after blinking. This shows that the blinkup sequence was successful but some other issue is preventing connection to the network (bad SSID or password, router issues, bugs etc).

Anyone having problems commissioning should look out for that green blink and report it so the imp folk can advise appropriately.

Fen Consultants, UK

No green blink for me either. Just fast red blinks after blinkup and return to slow orange blink. During blink up, no LEDS, so that means it’s not ambient issue. Any help ?

Something I found that helped was to face the imp card with the logo facing the screen, and covering up the back of the card with your thumb, having it at a slight angle. I just tried to commission an imp for the past 20 minutes, and that seemed to help. I’m thinking my phone is super flaky though with the app, however.

Yesterday I failed to commission my two imps with a $89 Polariod 7” Tablet running Android 4.0, and with BlinkUp 1.01 for Android. I tried various angles and distances from tablet screen and several brightness levels of the tablet screen. I tried various methods to block extraneous light sources, including: dark tape, cardboard masks with cutout size of sensor on both tablet screen and the imp, and even covering myself, Tablet, and imp with a dark towel. My son thought I had lost my mind.

This morning I awoke at 4 am with an idea, why not try it in the dark. So in my very dark office the setup was with the tablet face-up on my workbench and an April impee in hand on the tablet screen and a Hannah impee about a foot away on the workbench. I wasn’t having any luck with the April impee, then I noticed the Hannah impee flashing colors like crazy. I went to put the April impee down to check out the Hannah impee, and the April impee was now also flashing colors. Success! Both are commissioned now. Don’t know if this is repeatable, and I hope this helps others.

Both imps are flashing green very slowly, about 0.5Hz. Is this normal? The LED Codes chart defines normal operation as no flashing colors.

Yes, blocking ambient light can help altho I’ve not had to do it in the AM darkness myself.  I sit by a bright window and do have to turn my back to the window while also using my thumb to block out the light and this has always been enough.  I reckon AM or PM darkness may be necessary with a $89 tablet…

Both imps are flashing green very slowly, about 0.5Hz. Is this normal?
The LED Codes chart defines normal operation as no flashing colors.

@mondo: once flash a second is connected. They should be appearing in your planner. In a future release this flashing will stop after 60 seconds of good connection.

btw, I've never had to do blinkup in the dark. It's really not that picky - it IS however incredibly picky about framerate. One dropped frame and it's game over.

Android (pre 4.1, at least) drops frames for fun. You can often minimize the effects with a clean boot and killing non-essential tasks, but that isn't a guarantee. The next version deals with this pretty effectively though, by doing half-speed which makes it easy to catch most dropped frames.

This does mean that pre-4.1 androids will take about 20 seconds to configure, but that's a lot better than not being able to configure at all.

The downside is you can't get the new version without connectivity, which means you have to solve the problem once. We're working hard to get the new code into the bulk of the next production run so it won't be a problem for later users.

I looked thru various postings, and the LED codes … but perhaps someone can clarify a bit exactly what the expected startup for a new device should be.

For me, upon power on I observe the red LED at 1/sec.  It then goes off for the blinkup duration, but then flashes red 4-5 times at 2/sec rate, then returns to red at 1/sec.  (Note: I’ve only ever seen the red led flash … no green, orange, or yellow … and I’m still looking for a suitable Android phone to kickstart myself).

From the LED codes table I note orange signifies “no WiFi … run BlinkUp”.  (I believe this is where I’m at … but I observe red, not orange).

From a few previous posts on this thread …
   8/9    -  " … the amber LED never stops blinking"
   8/13  -  " … quick red flashes then back to the slow red blinking"  … (i.e. what I observe)
   8/16  -  " … Just fast red blinks after blinkup and return to slow orange blink"

So, from the posts I infer that a slow amber, red, or orange blink is observed/typical … from the LED codes I read that an orange blink is expected … and my observation is that I get a slow (1/sec) red blink upon startup.

Sorry I haven’t been able to sort this out from the documentation and previous posts, but I’d appreciate if I could perhaps get a bit more elaboration on normal operation and what should be observed.

Thanks in advance,

Hi Larry

From ths page:

Normal operation would be:

Slow Red (joining WiFi)
Red / Orange (connecting to cloud)
Slow Green (Connected)

I believe what you're seeing is repeated failed WiFi connections.

Fen Consultants, UK

Are you 100% sure it’s not orange? Fresh out of the packaging you should see orange flashes which indicates the device has no credentials at all (this is a discrete state as you can return the card to this state with BlinkUp before you give a card to someone else).

The fast red flashes after blinkup indicate a failed CRC, because your phone dropped a frame or three during the process.

You could always try using “clear wireless settings” on the blinkup app - this may work as it’s a very short flash code - and see if the light starts flashing orange, but that doesn’t actually help you get connected. The fact the led stops flashing for the duration of the blinkup means you’re getting further than some people, and it may be worth using a task killer to kill everything non-essential, then keep retrying - one blinkup attempt may work.

Other things to attempt, if you feel so inclined: try WPS (this is a very short setup packet, so may transfer without error) or set up another router with a very short SSID and password.

This week we’ll be releasing the slower Android blinkup app, along with the associated version of the imp software which supports both fast and slow blinkups. Once an imp gets connected, it can then self-update… but it is a chicken and egg problem right now.

Thanks for responses and explanations Rob and Hugo.

Yes, I’m 99.9+% sure that the only thing I’m seeing (or have seen) is flashing red.  (I’m allowing for the very slight chance that maybe I’m just perceiving the color wrong, or that I missed the orange blink a couple of days ago when I began commissioning attempts and wasn’t looking at it as carefully.   But over the past few days the slow flash I see prior to BlinkUp, the fast flash I see at the end of the 10-sec failed BlinkUp attempt, and the slow flash then once again are definitely the exact same color … red).

In response to your other comments Hugo …
  *  I had loaded an app killer yesterday, but still no luck after multiple tries
  *  Tried the clear wireless settings … but just got the slow red blink
  *  Tried WPS and a shorter SSID and password … but still no joy

The only possible issue for me at the moment then is why do I only observe a continual slow red (vs. orange) blink as I’ve never got the card commissioned properly.  No problem waiting for the latest Android (or upcoming iOS) app … just trying to understand if my device is in a proper state to be commissioned once they become available.  (I’m also still trying to locate an alternate Droid to see how that might work.  And I understand your comments re: the chicken and egg situation … I’m just trying to get that first successful BlinkUp!)

Thanks much again,

Ok, after some add’l attempts, I’ve got a new data point to report …

Tried the app “clear wireless settings” a few more times, and finally saw the green LED blink.  (First time I’ve ever seen the green LED).   Three green blinks observed after the command, but then back to the 1/sec red (not orange) blink.  From this point I tried normal and WPS commissioning again, but with the same behavior as reported previously … 4-5 fast red blinks at the termination of the BlinkUp sequence, followed by the 1/sec red (i.e. same color) blink.  Still no orange blinking anywhere to be seen.