Transmitting code to COSM has stopped working

As of a ~4 hours ago, the system stopped forwarding data to COSM (no xively) through the blueprint thing. Did something change there to break it? I don’t want to have to redo all the work in agents if the old system was working great for as long as it did.

I believe you will need to. As I understand it, the planner, nodes and the Input and Outputport classes are all deprecated. The good news is, @beardedinventor has Xively code on Github, that is really easy to use.

Posting from Agent to has also stopped working ~5 hours ago. I’m using example code found from

Code here:

here: function send_xively(body) { //take in csv value
local xively_url = “” + FEED_ID + “.csv”; //setup url for csv
server.log(body); //pring body for testing
local req = http.put(xively_url, {“X-ApiKey”:API_KEY, “Content-Type”:“text/csv”, “User-Agent”:“xively-Imp-Lib/1.0”}, body); //add headers
local res = req.sendsync(); //send request
if(res.statuscode != 200) {
server.log("error sending message: “+res.body);
}else device.send(“status”, (res.statuscode + " OK”)); //sends status to uart. this can be removed if not desired

res.statuscode has value 7 which according to libcurl means “Failed to connect() to host or proxy.”

I just tested a feed, and mine doesn’t seem to be updating either. I’d say its on the Xively end. I can’t imagine that they changed the API.

We had a brief issue in our backend, but it should be resolved now - can you two try again?

Looks like the problem is somewhere the Electric Imp side.

Sent identical request directly from my laptop to and xively is working as expected.

beardedinventor: Didn’t resolve for me. Still receiving http statuscode 7 “Failed to connect() to host or proxy.”

Agents should be working again (though we’re still investigating the root cause of the issue) - if you’re still experiencing problems please let us know.

As mentioned in another thread - checkout the impstatus twitter feed for up-to-date information about system status, etc.

Things seem to be working fine for me at the moment, with agents / http stuff behaving normally for the past hour or so now.

Xively feed update stopped working for me around 13.00 GMT 29/10/2103. Rebooted imp, no obvious errors. Prior to this has been running for couple of months no issues.

We root caused the issue - Xively are blocking our outbound IP completely. I guess we crossed some threshold with them that triggered this vs the normal per-API-key limiting.

We’ve contacted them to whitelist our server, will post when they’ve fixed this at their end.

Is the outbound IP still being blocked, or has the Imp server been whitelisted by now? I had an Imp/Xively setup that was working on Nov 3 but when I tried it again this morning my Xively was not working. Nothing changed on my end, as far as I know…

Anyway, just writing to see if anyone else is still having Xively issues, or if it’s just me? (Nov 6).

-Edit- I see I’m now supposed to use the Xively class on Github:

I’m having a bit of trouble getting it to work, so I’ll post on another thread.


Update (Nov 7)- Tried Xively again this morning with the planner and it is working now.

For me, it is working for at least 5 days now