Three slow green flashes, then two quick red ones


My latest imp (MAC address 0c2a6900010e) is behaving differently to the previous ones - and not in a better way. After blinkup, the Imp gives three slow green flashes (as if everything is going well), then gives two short red flashes. This pattern repeats indefinitely, and the Imp never shows up in the planner.

I’ve tried this Imp on several networks, all of which are known to work with other Imps. Likewise, it doesn’t seem to matter which Impee I put it into - it definitely seems to be something about this particular device.

Any ideas?



Hi Gavin

I see that this specific imp last connected successfully on Thu Nov 08 2012 08:19:52 GMT+0000 (UTC)…so it appears that it connected and is dropping the connection. We’ll see if there’s anything else to try or if there are any problems on our end and let you know if we need to send you a replacement imp.



Thanks Nong. If it aids your investigations, my other newest Imp (mac 0c2a6900037e) is also exhibiting the same behaviour.

Did You tried with blank code?
In my case this behaviour also happens with old IMP’s if my code has errors in it (the 3 green, than 2-3 red) and the planner does not shows the error. But it was there, the imp works well with blank code.

Attempting to recover with blank code is definitely the next step - a failure like you’re describing is most often caused by a runtime error in your squirrel code. Switch to blank code, then try commenting out most of your code and bringing parts back in block by block, with lots of server.log to see where you’re hanging up.

I’d change to blank code… if the Imp ever showed up in the planner! As it is, it doesn’t appear. So I can’t put any code on it, blank or otherwise.

So it appears to be coming up and should be appearing (it configures as toy alarm?). Have you tried scrolling about a bit in case it’s off-screen?

Weird - it’s not appearing, and I’ve scrolled around extensively (whilst zoomed out as far as the planner will go). I’ve even tried removing all nodes from the planner and re-starting the Imp, but it does not appear. And it’s still going green-green-green-redred. This happens with both of the most recent Imps, whereas the older ones work fine. Puzzled.

Have you recently changed your account password on the website, but not re-logged-in on the phone app? One possible cause of green-green-gren-red-red is enrolment failure (though this should be visible in our logs).


Nope, password has been constant since I signed up.

Do you have another account? I can only see two imps on your account…

Nope, just the one account. Should be 4 imps, though. This is really sounding like an enrolment failure… let me try again.

Nope, still the same behaviour.

Think I’ve worked it out; there was an issue with the old, old server that the first 1,000 imps made connect to on their first boot. Try again?

Interesting - after leaving one of the dodgy imps connected via a spare April board for two hours, it has now appeared in the planner. I’ve swapped it into the Hannah I was using initially, and it still seems happy… trying the same trick with the other suspect now.
…which is now happily upgrading firmware for a bit (solid green, right?). That also looks promising. Glad they both seem to be working - but that was odd.

Crossed emails. You sorted it. Gotcha :slight_smile: