Server log not showing

I have three imps that have been working fine for months.
They still work, I am driving them from an android app, so I can see that they respond, but there is nothing on the server log, for all three.
Does the new IDE need some kind of reset?

I have tried to do blinkup on them again, but nothing seems to work.
Please advise.

Are you using to access the IDE? plan.electricimp doesn’t work properly right now.

Yes I was using plan.electricimp.
Changed to ide.electricimp but it is still the same.
All three imps work, I can build and run, but no log.
The mac addresses are:
Really need some help.

I don’t know if you did something but 15 minutes after I posted my last comment all three are now working. Thanks if you did, otherwise ‘spooky’.

I spoke too soon.
Came out of the IDE and then went back in again and no log showing on any imp.


same here,

Using the ide and no log

I’ve had varying results today, from different PCs, all using Chrome. Sometimes logs are realtime, other times way behind realtime. It doesn’t seem to be Imp related. The same browser on the same PC will not get realtime, yet , at the office, it was fine. I’ve restarted and cleared. No joy.

There’s some work going on here; I have no issues myself (using Chrome on a mac) but it seems like the new load balancers are upsetting things for quite a few users.

We should have some resolution on this in the next few days I hope, by updating the IDE to use a different real-time push system for log messages.

@billmoultrie which browser? ide.electricimp is now set up to bypass the balancers so it should be the same as we’ve always had previously.

When new IDE come on, I recognise that “old” impees - registered but not driven for 2-3 month doesn’t show log, I see device and code but not log (Safari on mac). Turning these “old ones” ON allow to see log again…:slight_smile:


I am using Firefox

@peterAP after a while (I think it’s 3 months) of an impee not being active the logs go away - this is normal.

@bill could you try Chrome and see if it works? Would like to narrow down transport vs anything else.


Just ran into the same issue using Safari (5.1.7) for Windows (Running Win 7). Tried a Win 7 machine running Chrome and log message show up just fine. None present in Safari.


Just tried safari 5.1.7 on win7 and yes, the logs do not show. If I could find any debug console on safari I’d see what it was upset with, but I can’t :frowning:

The main suggestion would be to use Chrome; safari for windows was orphaned over a year ago and likely not a good thing to continue to use for security reasons.


Thanks for confirming the issue and for the advice. For silly IS reasons you don’t want to hear about, I can’t use Chrome on this machine.

Others have been using Firefox. Can you confirm this issue doesn’t exist with that browser?

Thanks again.

On my MacBook where Safari didn’t show the log I installed Firefox that indeed showed the log correctly =D>

Firefox is rather more up to date, so yep…

No logs in IDE on chrome for me. (Chrome Version 30.0.1599.101 m)

Console reports
Failed to load resource: the server responded with a status of 404 (Not Found)
Failed to load resource: the server responded with a status of 404 (Not Found)


Oops dropped the second console message

Failed to load resource: the server responded with a status of 404 (Not Found)

That’s… strange. I don’t see either of those errors on Version 30.0.1599.69.

There’s a (benign) error about not being able to load ace/theme-undefined.js but nothing else. Do you have the code editor up?