Red/orange blues

Hello all,

Received my imps whilst away on holiday, but yesterday managed to get a whole afternoon tinkering with them, and I’m impressed: very fast, flexible, and so much potential! I’ve cobbled together a simple Imp to Arduino bridge running over I2C (as I’m lazy with the wiring); this lets me take the potentiometer input from a Hannah, and send it to another Imp which sends it to the Arduino which then uses a car tachometer stepper motor to move a pointer to the same angle. I’ll post pictures and video shortly.

However, coming to try it this morning, one of my Imps (the one in the Hannah) now seems to be unable to connect to the cloud: it sits there blinking red/orange for a while, then goes to sleep. The other imp was left on all night, and is happily blinking slow green. They are both configured for the same wireless network, and I have tried re-blinkup-ing the recalcitrant one. This suggests that it’s unable to connect to the cloud, according to the LED codes page. Does anybody have any ideas?



OK, solved it. My wireless gateway (a hateful Netgear object, re-badged by Virgin Media) had decided to stop serving DHCP requests. It does that sometimes. One quick re-start of the gateway, and the Imp is now flashing slow green again.

Does it often stop serving DHCP? Obviously, if the imp is provoking it in some way then we need to look into that. Do you know the netgear model number?

Yes, it does - it’s a heap of junk. I don’t think it’s Imp related, as it quite often decides not to give out IPs to the iMacs as well (though the Mac Pros generally get away with it). I think it’s a WNDR3300, but it’s been rebadged so it’s hard to tell.