Older imp, was on the shelf for quite a while, will not update firmware

Imp is working but on an old release. Boots and runs just fine but will not update to a newer release. No errors or other indication in the log as to why.

Can you provide a mac address?

MAC is 0c2a69001871

This is currently expected, as upgrades to release 25 were paused whilst we addressed some issues. 25.2 should be rolling out shortly, and your unit will upgrade to that.