Old imp001s wil no longer blinkup


#1

I have dusted off two old imp001’s and April breakout boards that use to work. When I try connect them to a new network one will blink yellow when trying to connect but never does. The other one when trying to clear the configuration remains a blinking red and subsequently will not connect either. I am using the latest version of electric imp IOS on a iPhone 6. Any ideas?

Thnks


#2

Got the MAC addresses? The very oldest ones go to a legacy server and are told to update; it’s possible that there’s an issue here that slipped through testing.


#3

Thanks. 0c2a690024c0 and 0c2a69000121 are the MAC addresses.


#4

Mmm, can’t see those anywhere at all. I’ll PM you to dig further.


#5

The first of those is running 32.12 (and shouldn’t be going to a legacy server); the second is running 30.22 (and should be redirected to a current server with no further ado).


#6

0c2a69000121 finally connected afterI kept on trying.

When 0c2a690024c0 has its network configuration cleared first its amber and then a flash of green and then back to amber and stays that way when trying to blinkup. I will keep on trying.


#7

I don’t see 0c2a690024c0 ever connecting to our servers. Are both devices in the same location? What ISP are you using? I see the IP address that 0c2a69000121 connects from, but when I filter on that, I see a whole bunch of connections from that address, which suggests that your ISP is using carrier-grade NAT.


#8

Both devices are using the same ISP. When they first connected about two years ago they were using a different ISP. I will keep trying on0c2a690024c0.


#9

The green and orange flashes suggest the device is deliberately offline. Might be worth checking its code in the IDE, and clearing that there if necessary.


#10

Hi i have this problem, i have an old imp001 and try to use this week, i erase the data on the imp001 and try to program a new network, but it was impossible, doesn´t blink up. My mac is 0c2a690231c8.

i try with the laptop screen and my cel phone, but nothing change. Someone can help me?


#11

I’m not seeing any connections on our end for that imp001, which would suggest that there’s an issue with the blinkup. Did you check the troubleshooting docs?


#12

Hi, yes i check the troubleshooting docs. I will try whit another phone, and i tell you what happen. thanks for the help


#13

So, that device is not in our database so it’s very old. As such, it’ll be running a very old version of blinkup which did not support javascript blinkup or many android devices.

You may need to find an iOS device (iPhone, iPad) to get the device online the first time, then after that it will be able to be blinked up by any device.


#14

Thankyou i will try that


#15

Hi hugo, i finally can program my imp, i use a samsung phone and work fine. Now i have a question, this imp001 can be upgrade in the OS? and if is possible, how can i do this?


#16

It will have done the OS update when you got it connected - imps always stay up to date if they are online.


#17

Ok thank you very much.