Not getting a wifi uplink for imp in Hannah or April

I’ve tried multiple times to set up a wifi connection (using an android phone with the electric imp app) and haven’t had success yet in the Hannah or April development boards.

I plug the imp in and get a solid orange flash (about 1 hz). When I try to flash the wifi network, I’ll generally get a couple of quick red flashes (2-4) and then it will flash orange again. I’ve tried taping black electrical tape around the imp, and also holding my fingers around it to block out light. No success yet. 

I’ve also tried connecting to two separate networks with no luck.

Any suggestions?

Can you give me the make/model of your Android mobile device?  Also what Android version are you running as it should be v2.3 or higher.  Can you try rebooting your phone and trying again - several times and let me know how it goes.  We’re seeing what may be a similar issue on our end.

I’ll definitely try that in the morning, and I’ll get you the make and model of the android device as well as the Android version. 

It’s probably worth noting that we’re in a pretty well lit room, although as I mentioned, I tried putting electrical tape around the chip. 

So we’re using a Droid Bionic by Motorola with Android version 2.3.4

I forgot to mention that sometimes the imp shows no signal for a few seconds after the uplink before it blinks red. This pause is generally 4-8 seconds. On one try it didn’t blink anything at all after the upload, and we had to eject and reinsert the chip. 

Can you try a different Android phone?  Possibly one of the of the following altho any other Android phone will work: 

  • Google Nexus One
  • Samsung Galaxy Nexus
  • Samsung Galaxy S III
  • Samsung Note
  • Motorola Xoom
  • LG VS740
We expect our iOS app to be much more robust and anticipate approval soon so if you have an iPhone...

We tried a different phone and it looks like we’re linked up now.

The new phone that worked:
HTC Glacier w/ Android v. 2.3.7 + Cyanogen


Thanks for the update and info, Sam.  I’ll include it on our dev wiki.

Id like to add that sometimes with mine I had to lay the imp on top of the screen and not touch it in order for the blink up to work. just a suggestion if others have problems.