No light in chip

i inserted chip in the board and connected the board to mac using usb cable… there should be a red light on… but nothing happens…no light no response… i used april board and powered it externally, its POWER light is on…(thank god)… yes… but when i inserted the chip… the power light of board is still on but the light in chip doesn’t glow… please help me …

Put the imp card into the April’s SD slot first and then connect the April board to USB. If the April is a red one, from Sparkfun, you’ll need to place a jumper on or connect the two metal pins on the upper part of the board, marked USB.

What you should see now is a red light blinking inside the white imp. You will need to use the Electric Imp app - available for Android and iOS - to send your WiFi access details to the imp. To use the app, you’ll need a free developer account; you can set that up here:

Our Getting Started Guide has all the details you need.

what is “the jumper” you are talking about?? Is it this one yeah, i have the red board from sparkfun…do I need to connect the two usb labelled pins to each other with a wire directly???

moreover i am not able to access the Getting Started Guide… it is asking some username and password… :frowning:

There is either a row of three holes or a row of three metal pins next to the GND and VIN edge connection holes. These are labelled BAT on the left and USB on the right.

If this has been populated with pins, then just slip a jumper on to connect the middle pin to the right USB pin, then it will work from USB power (it should have come with the April).

Mine came unpopulated, and I fitted little slide switches to keep the height down. You could also solder the middle pin to the USB pin, but then it is harder to change to battery / external power.

I agree with you about the Getting Started Guide link, try, which you reach from the electric imp IDE then selecting the documentation link at the top. This has a photo of the board and the power jumpers.

Sorry, @umeshksingla - I pasted the (slightly) wrong link in. Fixed now, though @DrJack got there first with the right one.

Yes, you can connect the pins directly.

yes, i got it. Thank you @smittytone and @DrJack

Have you seen the light yet?

Hi @DrJack, i got the reddish orange light in the chip but after going as per this video tutorial i am not getting the green light… but after sending blinkup from my phone and keeping the screen with chip, the orange light continues to glow…but i noticed a blood red light after this which blinked about 5 times and then again changed to orange…pls help

I’m not quite sure from your description what the exact sequence of colours is or the rate at which they are each flashing. I’d suggest you visit the BlinkUp Troubleshooting Guide which has a list of the sequences - and videos so you can confirm you’ve found the right one.

Match up what you are seeing on your imp with the sequences listed here and you’ll be a long way to solving the problem. It sounds like some disconnect between your imp and your router.

I would also use the app to clear the imp’s WiFi configuration. Remove the power from the imp, plug it back in and then run the clear configuration BlinkUp immediately.

If you are still having trouble blinking up, I would suggest using an iPad or iPhone to run the app, that seems more reliable than Android.

Hello @DrJack and @smittytone , Now I have set my imp and got it connected to the wifi. The green light finally glows now. I am done with experiments on led lights ( HelloWorld concept) and tried different delays and all are successful.Thanks to you both.
DrJack, I didn’t need an iPhone or iPad, only thing it needed was total darkness.

But I again need help.I can’t understand the concept of agents.What is agent Url??From where i can get it?? Should I do as per I am directed on this page

Do the urls given under the ‘Testing’ area are to be directly used or are they just the sample???

Your agent url is at the top of the IDE when you select an Imp. The agent is a programmable web service that you get with every Imp. You can program it to do whatever you like, and it runs all the time, even when your imp is sleeping.

thank you all. it worked successfully.

Now what to do next???I mean could you people suggest any beginner level projects to move further??

Take a look at the Next Steps page in our Getting Started Guide - it lists some easy projects you look at building!

@umeshksingla, you might like to add the following code snippet in place of the response.send(200, “OK”). It will give you a little web page with on and off buttons to control your led.

local resp = "<html><head>Control the LED</head>" local thispage = "<i>device id here</i>" resp = resp + "<br><body>" resp = resp + "<input type=\"button\" value=\"ON\" onclick=\"window.location.href='" + thispage + "?led=1'\">" resp = resp + "<input type=\"button\" value=\"OFF\" onclick=\"window.location.href='" + thispage + "?led=0'\">" resp = resp + "</body></html>" response.send(200, resp)