"no agent running"

Hi, I’m stuck. I have an Electric Imp “developer edition” that I bought about a year ago together with a Sparkfun breakout. Back then I used the Planner etc. Today I revived the imp and had to “Legacy BlinkUp” it, so I guess I have one of the first models.

I got the device part of the IDE working and sucessfully interfaced it with an SPI LCD display. Now I want to control this via HTTP(S). Problem: I seem to have no agent URL and I have no idea of how to get one. In the device settings it says:

“External URL:
None - there is no agent running.”

I then read that agent IDs are somehow bound to the “impee”? Wouldn’t this be the breakout board in this case? Do I have to register an impee somehow?

I’d be very grateful for any help.


Have you put some working code in the agent panel?

Hey Dolf,

I think so, at least I get no errors. The code is:

server.log("Color: " + http.agenturl() + “?color=123”);

function requestHandler(request, response) {
try {
if (“color” in request.query) {
device.send(“color”, request.query.color.tointeger());
response.send(200, “OK”);
} catch (ex) {
response.send(500, "Internal Server Error: " + ex);


server.log("Color: " + http.agenturl() + "?color=123");

does it log this?

Nope. I guess if it did, then I’d know my agentUrl :expressionless:

Does it log anything?
What colors do the leds show?
Does the upper bar in the agent pane (same line as “Not running” line but then at the left side) show anything?

No logs from the agent. Only the device part logs correctly. The device is “online”. The agent bar says nothing except “Agent” and the fullscreen button.

The device LEDs blink green and then turn off. My program starts and successfully communicates via SPI with an LCD panel. The agent is simply not there, though.

Have you tried to reload the IDE?

put this line of code as first line in the agent pane:
server.log("agent firmware version: " + imp.getsoftwareversion());
Does that log something?

I reloaded the IDE many times and deleted and re-created the Device multiple times. I’m sorry to say that inserting your code in the agent part does not log anything, as the agent is not running. I think it is a bug/technical issue in the imp backend. I just don’t know where to get support, as there is no support email address in the contact section of the website.

The only thing I can think of, is to create a new model, with only my line of code.
Otherwise, those guys that have control over the server-side buttons will jump in.

I suppose that you have missed some device updates.
It can be updated manually with the help of those guys.
What log do you get when you put this line on the first line in the device panel:
server.log("device firmware version: " + imp.getsoftwareversion());

Device updates would apply automatically, and shouldn’t affect this. Looking into it…

I am experiencing the same issue, the IDE says there is no agent running,
everything on the device side executes correctly and the agent side doesn’t seem to execute at all.

I have tried creating a new model, deleting the device and re-blinking up the device.

There are no blink codes either.

2014-01-18 14:30:38 UTC-5: [Device] agent firmware version: af0f28a - release-27.10 - Fri Dec 13 11:08:38 2013

Very strange. Looking into it tomorrow.

Thanks! My project is so close to completion, this is blocking me from completing the last bit of it as I am trying to interface with an HTTP API and I’m very anxious to finish it :slight_smile:

Trying to work out how your agent failed to be created, but fixed for you now!

Thanks, it’s been working great for a day now!