Legacy BlinkUp for 6 month old imps failing

I have recently been able to pick up work on my Electric Imp project and wanted to hook up my two developer edition imps in april cards to the network, but cannot get past blinkup. One Imp was previously hooked up to a no longer existing network.

I have:
One imp flashing red 1hz on powerup (wrong wifi credentials I think)
One imp flashing orange (ready for blinkup)

I have tried blinkup with: Nexus 4 / Galaxy Tab 10.1/ Galaxy S3 /Nexus S on two different wifi networks (both below channel 11) with and without WPA2. I have tried in the dark, with fingers and tape on the card, all to no avail.

In normal blinkup mode the cards understand they are being blinked at (stop blinking orange or red but sometimes blink once or twice during the blinkup sequence). In legacy mode the card does not even respond to the flashing screen, even in the dark. I have disabled all power savings I can find.

I do not get a green or red flash after the sequence. Rather, I get a long pause (no blink, for 20 seconds) followed by either nothing or 4 fast blinks.

What should I do?


If you get any blinking during blink-up, I believe you are not correctly communicating. The LEDs should go dark while the screen is flashing, and then start flashing when blink-up is complete. Newer Imp firmware helps take care of the issues in the variation of Android devices. Your easiest solution might be to find or borrow an iOS device, get connected and get those Imps updated to the new firmware. Then you should have more success blinking up with Android devices.

I had that problem as well. I cannot blink-up my 001 imps in an aprilboard.
I had to use my arduino shield.
I can only think of a power issue.
Glad we have software configuration now.

Thanks for the quick replies guys.
I will try finding an iOS device, or perhaps move to IMP002’s altogether.


On any samsung products, turn off powersave mode - this may help. When they come online and update, you’ll find 27.9 is much more tolerant of phone settings… but that doesn’t help you if you have devices on an older version.

hi Hugo,

Tried an iPhone and it worked immediately. Have them updated and now they work with all android devices as well. It took me 2 hours afterwards to turn them into Xively-logging temp/hum sensors. Onwards and upwards :slight_smile:

Glad you got online, I’ll be very happy when all the old imps out there have got upgraded :slight_smile:

Ok so I’m running my course with eImps for the second time, they are 2012 ones, last year I was OK with the iPod Blinkup, Blink up on Android Samsung does not work,

The iPod Blinkup, now does not seem to work, waits for network , does not go green, red orange or possibly orange to red. Do I need to upgrade firmware or something?

iOS7 made the very oldest iPod/iPhones a bit sketchy - you may have to turn the ipod off and on again then retry blinkup.

What exact iPod are you using, what OS and what’s the mac address of your card?