Iphone commisioning green to red

Green blinks go to red fast blinks and then all over again. Never turns up at the homepage. Gets stucked in that loop, does not matter which wifi. Breakoutboard v11 and a sparkfun bmp085 soldered. Usb powered. Answers ok after sending blink. Any ideas?

Sounds like a code error in your code (fast red blink) which is happening before your device does an imp.configure() (which makes it appear on the blueprint).

Go to the code editor, copy our your code and replace it with imp.configure(“test”, [],[]); then save and plug imp in again. It should appear.

Then, paste the old code back, and use the “edit” button on the imp to enter the editor and see the errors as it boots.

Thanks for your quick reply Hugo! However I woke up this morning and realized I changed password on the login a while back. I never changed it on the app though after I comissioned my first imp! After changing the password in the app my second imp connected just fine :slight_smile: Perhaps have the possibility to have a check settings in the app to see that both wifi and login works correct before sending blinks to the imp? Easier to interpret a text error in the app than blinks on the imp.

Yep, we’ve talked about that but I don’t see it in the todo list. Will add…

I have a similar problem, but it cannot be logically connected to bad code:

  • the impee works fine with an imp card that I’ve been using in our lab for months without any problem
  • i’ve tried 3 brand new imps, done the blinkup on the same access point. All goes well, it seems to lock on the Wifi, but immediately after, it goes into the fast red blinking. Impee never appears online.
  • I’ve tried with another ‘old’ card and again, works perfectly fine
  • tried on two different physical impees, identical behaviour on both.

Any idea ?

Dirk

PS. I’ve used the simple test program above. Same stuff…

Can you give me the mac addresses of the cards? It could be the brand new cards are attempting to upgrade and depending on how old they are, they have different LED codes (and may be hitting an issue with upgrading).

BTW, i assume that the ‘old’ card has the most recent firmware (as it was automatically updated, while the new ones run a version of at least 8 months ago (when I ordered them);…

Here’s 4 of them, but I suspect will be the same for all those that have not been used so far (hence run a very old firmware (haven’t unboxed all of them yet)
0c:2a:69:00:28:0b
0c:2a:69:00:28:33
0c:2a:69:00:28:6e

Here’s the MAC from a card that works just fine:
0c:2a:69:00:26:FA

the fourth bad one:
0c:2a:69:00:27:69

This is because you have likely changed your password, but not logged out of/back into the blinkup app, hence they are being configured with an illegal token (it doesn’t know which account to put them on).

Log out of the blinkup app, log in again, re-blinkup and you should be fine.

OK, I’ll try that, but I can’t remember having changed passwd ever…maybe accidently

This solved it…
Does the Blinkup app do a validity check on account info ? I haven’t changed my account & passwd since the beginning as far as I can remember, but still it seemed to have been corrupted in the imp app, so the only scenario I can think off is that I entered wrong info one way or another that was not captured by the app before pumping it into an imp card…

It doesn’t, no, but it really ought to. Sorry for the trouble.