Initial Blinkup Error - Green [3X] then Red [11X]

Hi, I’m just getting into the imp game with two brand new imps (macs 0c:2a:69:00:1f:9f and 0c:2a:69:00:1f:8b) and April boards. I’ve tried every combination of imp and impee, but I can’t seem to connect after blinkup. Following the directions here, (and after using the “Legacy Blinkup Mode” on the app), I get to red-orange-off for a second or two (‘getting IP address’ status), but then I just get three long green flashes followed by 11 or so fast red flashes, repeating indefinitely. I don’t think I ever got an “on green” indicating firmware upgrade. Neither imp nor impee shows up in my planner, but I checked my wifi router client list to verify the imp (as recognized by mac address) is indeed connected to my wireless network.

I’ve tried to RTFM, following similar forum posts:

Hence I have tried logging out and logging back into the phone app to no avail. A run-time error can’t be the problem (unless it’s present by default) since I have never even connected the imp to the planner.

The latter of the above posts mentioned a nuance with the “first 1000 imps made.” Might I have some old stock from throwing me off? What’s the proposed solution? Thanks in advance!

Both of those imps have invalid blinkup tokens, which is why they’re behaving like that. Did you blinkup again after logging out and in on the phone app?

Yes, I did try logging out and logging back in before, and I tried it twice again after your post with the same result. But to take your suggestion a step further, I went into the phone (Samsung Galaxy S II Blaze) application settings, did a “force stop” on the imp app (didn’t know it was still running in the background), and also “clear data” for the imp app. Then from scratch restarted the app, and then the blinkup worked for 0c:2a:69:00:1f:8b as planned. (I mention it here in case anyone else runs into that same problem.)

However, I then had a new problem with 0c:2a:69:00:1f:9f. Repeating the process for it, and also running the “clear device settings” blinkup, I made it back to the orange blink ‘No WiFi settings’ state. But then any, and I mean any, blinkup with the proper wifi data resulted only in three immediate red pulses, then back to orange: ‘Failed to receive configuration via Blinkup’ according to the key, ‘check your SSID’. This was an even more basic error than I got with the original “invalid blinkup tokens” problem previously identified.

I tried dozens of times, restarting my phone, completely uninstalling then reinstalling the app, going into a pitch dark room, placing my fingers in various positions on the imp during the blink, using the ‘connect using WPS’ method, even going so far as to change the SSID and password on my wifi (and of course changing it correspondingly on the app). Always with the same result, three red blinks then back to orange. What’s more, is that the “clear device settings” blinkup always resulted in a ‘success’ short green light, so I knew that communication wasn’t completely blocked.

What finally worked for 9f was clicking “change network” and manually typing the SSID and password, instead of using the default as presented by the phone’s wifi state. Finally success, and both imps are now online in the planner.

So hopefully this post helps others who may be running into the same difficulties. I won’t point fingers too hard at the app, since my phone (model SGH-T769 with Android v4.0.4) wasn’t listed as a ‘’, but I do hope that the programming stage is much more enjoyable than the setup stage. Thanks for the quick help all the same.

That’s kinda strange; red blinking at the end of a blinkup means the blinkup packet was corrupted (failed CRC check) - changing network setup has no effect on the imps behavior if you can’t tell it the network details.

You always have to type the wifi password though; we can’t get that out of the phone’s OS on either iOS or Android.