Imp005 wifi 5Ghz


#1

Hi,

I just received my imp005 kit, and I’m having trouble connecting it via 5Ghz wifi, it just connects by 2.4Ghz or I saw cable.
I would like to know if I need to do any configuration so I can connect it to the 5Ghz network.
Note: I am a beginner, I do not have much experience, thank you in advance for help.


#2

No, there’s no special configuration for 5GHz other than the usual BlinkUp. You just use the Electric Imp app to select a 5GHz network, enter the password and do BlinkUp, and the imp005 will connect.

Do your 5GHz and 2.4GHz networks have the same name? If so, the imp005 will probably connect to the 2.4GHz radio first (I don’t know this for a fact, but most of the various devices I have encountered do).

FWIW, I keep my 2.4GHz and 5GHz networks separate for this very reason.

If your networks do not use the same name, you should note that you can only store one network on the imp, so if you BlinkUp with the 5GHz network and then immediately re-Blink with the 2.4GHz network, the imp will only remember the second one.


#3

smittytone,

The networks have different names, before adding another network I’m deleting the network saved in BlinkUp, even so it does not connect.
Do you have any configuration on the router that you need to do?

thank you


#4

BTW, you don’t need to clear network A from the imp before adding network B - adding another network automatically clears the first.

When you say, ‘does not connect’, what colour pattern are you seeing on the imp LED?


#5

Hi,

right after using BlinkUp, when the app is trying to connect, the LED flashes red, then blinks amber color, blinks for a few seconds and stops blinking, equating this in the app already has the msg that could not connect .
I’ve visualized the color scheme at this link: https://developer.electricimp.com/troubleshooting/blinkup/#codes

I connected the same in the 2.4Ghz network and circled the script inside the device, follow the link of the page:

Without success, I can connect it to any 2.4Ghz network, but when I try on some 5Ghz it can not communicate.


#6

There are three possible combinations of red and amber, but all of them happen after the imp has connected to the wireless network, so your link is failing at getting an IP address, resolving the name of the Electric Imp server, or connecting to that server. I’m assuming you’re not trying to work with a proxy server.

Note that if the imp was NOT connecting to the local network, you would only see red flashes (long flash plus two or three short flashes).


#7

video imp005.zip (2.9 MB)

smittytone

I’m not using a proxy on the network, it follows a small video that I made soon after trying to connect it on the 5Ghz network.
I have tried to connect to both active DHCP and static IP.
Once again thank you very much for the help.


#8

What country are you in, and what channel is your 5GHz router using?

The 005 devboard is configured for U.S. channels. I believe it’s possible that your router could be on a channel which is not valid in the US hence the imp can’t see it.


#9

Hi Hugo,

I am in Brazil, the router is operating on channel 40, the imp can not fill the router, I am sending a photo attached


#10

If scanwifinetworks can find it, then it’s supported (and yes, ch40 is ok - if you were in India, for example, and on ch 169 or 173 then the imp wouldn’t be able to see the AP).

Can you do this:

  • Blinkup to 5GHz network. Let it try to connect for, say, 30s
  • Blinkup to 2.4GHz network. Let it connect.
    (no power cycle or reset between these two)

Then ping us with a timestamp of the 2.4GHz connect. We can then examine the logs from the device and see what it thought was up?


#11

Hello

After several tests, I was able to connect the imp005 to the 5Ghz network.
In the router the channel width was automatic, I changed to 20, 40 and 80 Mhz, the only one that connected was 40Mhz, I changed the router leaving the fixed width and I had no problem.

Thanks to everyone who tried to help.