IMP not showing up

I have an IMP project working at home, I brought it to install it at work but the imp no longer works.

I blinked it with the Wifi network at work and seemed to go ok, lots of flashing and a short green flash.

The imp isn’t showing me any output in planner which is odd.

The light is mostly off but every few minutes it flashes red/orange looking at the codes, that means that it is connecting to the cloud.

This is a bummer as I am supposed to install it today.

Any ideas?



Flashing red/orange means trying to connect; it needs to go green to confirm actual connection.

Does your work wifi have a username/password (802.1x auth)? If so, the imp does not support that…

Nope the wifi is just WPA no username or password just a password.

What phone? If you’re using the android app and see quotes around the SSID name, you need to remove these manually right now…

nope iPhone4. It works on my home network but not where I am planning to install.



When you go to planner and click on the “impees” link, do you see the imp?

If the light on the imp doesn’t go green, it’s not connected…

100% sure the password is typed correctly?

Miseim, I do see the imps in the planner but I see imps that are not even powered on so that doesn’t really help me.

Hugo, I tried re-inputting the password many times and still no luck.

This is driving me nuts…

There are no other wifi networks in the building I can try either to help debug.

Any other ideas?


Take it back home again and try it.
Maybe something happened along the way?
I know … it’s a long shot, but who knows?

Is there a way to find the MAC address of my imp? There is another wifi network I could use but for security it only lets selected devices connect.

If I have the MAC address then I could ask the wifi admin to add the imp.

I thought it could be the IMPO id found in the planner but that has too many characters.

MAC address is printed on backside of the imp, but I suppose you can find it also somewhere in the router logs, like associated devices

imp.getmacaddress() returns a string of 12 hex chars

Ok, it works perfectly on the other wifi network (once I gave our admin the MAC address). No idea why it won’t work on the network I had planned to use but at least I have a workaround.

Thanks everybody for your help.