Imp IOS login error

I’m getting this right now <>Login Failed. The certificate for this server is invalid. You might be connecting to a server that is pretending to be ‘’ which could put your confidential information at risk</>

Whats up?

Are you still seeing this? I’m not able to replicate here.

yes it is still occuring. is the note on the IDE based on this error?

No, the IDE not is not based on that. What phone are you using, iOS or Android? (I’m on iOS)

The error is occurring on an old IPOD touch version 4.2.1.
I just checked and I am still getting the error on that device.

I was able use my account and wifi to blink up from another device (android).

Hmm. I’m wondering if there are expired root certificates on that device as it’s quite old. Do you have any problems going to from the browser on the iPod touch?

It works OK on 4.3.2 for Iphone. What’s the oldest we actually test against?


Initially the load gave me a certificate error which I was able to ‘continue’ through.

The login page seemed to work as I was able to log in.

The IDE page is barfed. All charcoal grey with only the ‘EI logo and electric IMP’ in the upper left corner of the screen. Nothing else is shows; no links and no other text.

I never went to the IDE with this device before, so I don’t know if it ever worked on this device.

Sorta sucks if this device isn’t usable anymore; Blink up is about all it was good for!

If you’re getting errors in the browser this sounds like root cert issues. I’d suggest upgrading to 4.3.3 if you can?

(looks like that’s only an option for the 3rd generation one though; if you have a 2007 or 2008 model it’s too old I’m afraid)

Safari does this. It doesn’t manage IDE changes at all well. If you log in, don’t log out but quit Safari, and the IDE changes, when you run Safari and go back to the IDE, Safari will (it seems) get the content which isn’t secure (ie. what you are seeing) and be unable to get the rest. The only way I have found to resolve this is to manually go to the log-in page and click the log in button again.

I think when the IDE changes, it automatically logs users out. Safari doesn’t register this (other browsers do) which is why it gets stuck.

I would also change your bookmark from to The former is auto-routed to the latter, but you can remove this from the list of possible causes by making the bookmark switch.

Hyperone, could you post more details of the “certificate error”?

Bit of a shot in the dark, but is the time and date set correctly on this device? If it were way off, then that would affect its opinions about certificate validity.


Hey everyone…


Yup, Peter hit that one; I checked the time which was correct, but the date was Jan 1970

Changed the date to current and problem is solved.

Sorry for the run around I should have checked that first thing when the cert failed.
Thanks everyone!

PS: The safari problem with the IDE remains without the planner URL. I assume that the IDE is not compatible with this IPOD touch safari version. That is not a problem for me.