Imp can't get through corporate wireless

This weekend I set up an Imp to work on my wireless network from home.  Everything went flawlessly.  This morning I came in to my lab at work to set up an Imp to operate with my company wireless and I hit a brick wall.  Here is what happens -

I typed the wireless password in to a note on my Samsung Galaxy III running Android version 4.0.4.  I went to the wireless network settings, found my wireless network, and pasted the password in to the authentication dialog box. Once I verified that my Galaxy phone had indeed successfully connected to my company wireless, I then opened up the Electric Imp App and there waiting for me was the name of my company wireless connection.  I pasted the password in to the app, removing fat fingers from the equation.  The Imp stopped blinking orange and went dark while the Blink Up process completed.  Once the Blink Up process completed it blinked green once, then blinked red/orange a few times, then fast blink red forevermore.

I downloaded a wireless analysis app (WiEye) and here is the information I get on the company wireless -

Strength: -85 dBm
Channel: 11
Frequency: 2462 MHz

The password for the wireless is 15 characters long consisting of a mix of alpha-numeric characters (nothing exotic).

Fast red is can’t connect to server, but wifi join and dhcp was ok.

My guess is the company firewall is not letting traffic through on port 31314. Can you ask about that? Fallback to using port 80 is something we’ve discussed but it hasn’t been required as yet.

That was indeed the problem. Most companies, including mine, block pretty much everything except 80, and sometimes 21 / 20.  My networking guys sniffed the network, grabbed the MAC address of the only device they found trying to get out on 31314, and poked a tiny little hole just for the one Imp.

I like your networking guys :slight_smile:

They could wildcard the mac address and that port if they wanted a more general purpose solution…

same problem here, I can’t get to connect to corporate wifi and /or personal hotspot

Got any info on the types of network you’re having problems with?

We don’t support 802.1x, which is quite popular on bigger corporate networks, but personal hotspots should be fine in general.

The corp networks I’ve deal with recently also allow outbound to port 8080 as well as 80 and 22 (ssh).
Perhaps you could support connections on 8080 rather than tinking with your main webserver port?

My imp cannot get to the server through my S3 hotspot. The imp has connected to my phone, I can see one connection when the imp is powered. But the imp blinks red/orange/green all the time. I have tested my hotspot with my notebook, it is OK. The hotspot I am using is FoxFi, my phone is on the NextG network (Telstra 3G network in Australia)
I shutdown my hotspot, the LEDs are still blink the same pattern.

Some part of the planner seems not using the same network credentials as the browser session, when I am using it within my corporate domain, the proxy login dialog keeps popping up.

If it’s going red/orange/green, that means it’s running the old, old factory firmware and attempting to update itself… has this imp booted on any other networks?

The usual pattern you’d expect to see would be red/orange/off, changing to orange/red/off after DHCP but whilst trying to get the first server connection (this second code was added in release-3).

My imp firmware has been updated over the weekend, and it is now working on my S3 hotspot (same settings as the failed attempt before, details in previous post).
With the new firmware, seems it does not want to be Blinked up with different network settings when it has been set and working, even not connected yet. I can only get it accept new settings by Blink it on start up when red LED still blinking.

Hmm, strange. Is it definitely accepting the blinkup? (ie, does the LED stop flashing during the blinkup process, then flash green immediately afterwards?)

It’s definitely happy being reconfigured when it’s online, I do this all the time.

Yes, the card did accept blinkup because I have changed the settings from my home settings to the hotspot settings which never worked before. When I was trying to blink up at home earlier, I could not do it either, I thought it might be connected to the network, therefore not accepting blinkup.
I have tried WPS settings tonight, I could not blink up it either. I have tried 3 times and then I disconnected the power to imp, and started WPS button process and then connected the imp. The imp accepted blink up and connected to my home network.
In the WPS process, I didn’t understand how it behaves, seems as soon as the connection is made, the WPS LED on the modem stops flashing. I have blinked the imp number of times. It seems like before the imp is stable in operations, it will accept blink up.