Imp blinking green quickly, but doesn't show up in list

I got my hannah board to work, but for some reason, my two aprils aren’t connecting properly - the wireless seems to connect fine (initial amber flashes -> some mix of red and green for a few seconds -> fast green), and the imp shows up in the dhcp clients on the router.

However, the april impees never show up in the list online. Possibly related- the hannah board shows up twice, once as hannah.default and once as the temperature logger that i have loaded currently.

I’ve tried resetting the wireless settings, power cycling, etc. So far no luck

It seems like the impees arent the problem, might be the imp itself.

Swapping the known working imp into the april board made it show up in the impee list, but the non-working imp didn’t work in the hannah board either. It did seem to run the temperature logger program for a second or two (values showed up in planner), but then it continued flashing green quickly and stopped showing values. It doesn’t seem to respond to the firmware update flash sequence either.

Also tried switching the wireless to unsecured, still didn’t work.
the misbehaving imp is: 0c:2a:69:00:06:55

Hi - Thanks for providing the MAC address of your card. Seems that it has not upgraded to the latest FW. I’ve pushed the latest FW onto it but it probably won’t take since it seems to have trouble connecting at all. Your problem imp looks similar to this issue: If it is, we’re working on this so please stay tuned.

Thanks for your patience.

Yep, no luck- still flashing green quickly. Thanks for working on it!

Hi Nong - I’m having the same problem, my imp’s MAC address is 0c2a690003bb.

When you say “flashing green quickly”, do you mean a short then a long flash? If so, that’s the first phase of a firmware update.

However, I don’t see your imp trying to fetch firmware so something else strange is happening. We may need to swap that one out for you to work out what it’s up to.

@ianjb: yours is on the latest sw. Can you describe the issue you’re seeing as it doesn’t seem to be the same as what the others have seen.

Having the same problem. Blinked up fine.
But Planner does not show imp and code does not list connected imp.

mac is 0c2a69001068

Hi Hugo,
Thanks for checking the SW on my IMP. I described my issue in this thread:
I haven’t power cycled the imp and now it’s stuck with “line 0: impee offline” in the code editor error tab although the imp is still flashing green as usual.

fourthandvine describes what I’m seeing in this thread:

It sounds like several others are seeing somewhat similar issues and feel confident that you’ll get to the bottom of it soon.


After carefully reviewing the blink code table , I figured out that I was seeing the successful blinkup ( Fast green flashes) but what I needed to see was the connected set of flashes (very slow). This is an important observation for everyone.

Once I figured this out, I switched networks(not sure why this worked) and the unit blinked up again fast green, but then went to solid green. I knew this was upgrading to the new firmware. Once this occurred, I cycled power on my sparkfun arduino adapter, and VOILA I see the imp on the planner.

Even though I had some difficulty, the power of this device and it’s strategy is well conceived.

@hugo yes, one of the flashes is longer than the other. average rate is probably around 1.5 hz or so

Hi folks - We think we’ve fixed this problem. Please let us know if you experience otherwise.

Just went through (today) the same experience as “hroysterimp”, had the 2hz fast green blink. Had to power cycle a few times and reblink - eventually it came back up, went solid green, new firmware and all was good.
Originally posted here as well:

If you had the “fast green blink” - leave it! It’s upgrading. It’ll go solid after it’s verified the image, flash the new code, then reboot. There’s no need to reblinkup.

Okay, I now have a second imp so that I can begin to coordinate the 2.

I know you have said leave the fast green blink, but I have waited, the cows have come home, and the device does not upgrade the firmware. I know now that until it does, the planner only briefly sees the imp connect, reports the bootup, and then reports it offline.

At this point I am sure that there is a problem somewhere in the firmware upgrade.

I will continue the power cycling. Also in the first one, changing wifi targets seem to “trigger” the firmware update. I concur with “richgps” observations. Mine are identical to his.

Still watching the fast green blink - waiting - I will report any success when it occurs.

Success, again not sure what made the difference but multiple power cycles and multiple reblinking to and from 2 wifis that I operate caused the firmware update, appeared and stayed active in the planner.

I will now see the usefulness of have them interact(the whole point - right?).

We’ve had reports of trouble with firmware updates on routers that are using google DNS; we’re not sure why right now but are looking into it.

Was the wifi you had trouble with using the Google DNS servers?

Yes, I see where you are going with this.

I have been using the imps at one of my clients sites.

They are using AT&T DNS. I hope that helps. Also I will be buying more so I will initiate/upgrade firmware from my home next time, which will introduce another DNS link.

Thanks for taking another look at this

Is it by any chance a AT&T 2701HG-B running

If so, that has a known issue with DNS which we’ve been looking at.


I am facing the similar issue with my device to register.
One time I was able to register successfully and was listing on the imp.
But I deleted from there and now try again register it but it is blinking green and red continuously and after a minute orange.
my mac address is : - 0c:2a:69:00:15:3c
So can any please help me out the procedure ?


I can see the device connect ok. Try again, see if it appears in new devices?