HTTP Request planner stopped working

Hi I’ve had a server outage planner HTTP Request was showing 404.
My server’s back but HTTP Requests aren’t working.
I’ve changed url, deleted/re-inserted & tested them using Nothing!

Any ideas?

Thanks as always

@controlCloud - If your http request is returning a 404 it means it’s managing to send a request, but there’s nothing listening on the other side.

I just tested this by hooking up a TickTock node to an HTTP Request node pointed at a request bin, and it seems to be working fine (heres the bin:

What do you mean by you’ve changed url?

I was getting 404 as the service was down for 48hrs it’s back up and HTTP Request just won’t send nothing. I went out shopping came back now working fine wonder if this pattern can be applied to other issues :slight_smile:


Can you give any more detail on the HTTP IN problem you saw? It definitely wasn’t widespread (for one, I use HTTP IN to control some of my lighting at home and so know quickly if it’s not working), but we’d like to debug a bit further.

If you can PM the HTTP IN address you had that showed issues that would be helpful.

Hi it was HTTP Request issue & I don’t check response so sorry
The site handling request was down 48+ hours
After it came back HTTP Request on planner still showed 404

I tested the my site api and it worked
I then tried a different url in HTTP Request didn’t work
I deleted all HTTP Requests & rebuilt them
Then hour so later they worked!

I wonder if the issue due to the my site being offline line for so long and the imp still trying to post a lot of messages?

Hmm, shouldn’t be, but there may have been an issue with the result display on the HTTP request planner node due to recent changes. Ideally, using an agent is the best way forward!

Yep for Agents, but awaiting Agent Storage before refactoring both imp & my.server code