Help - Blinkup failing

I just recieved two electric imps, and can’t configure them. I’ve tried different phones, different imps, different boards (both April), legacy mode… nothing works. After the blinkup, I’m getting a single fast red flash followed by continuous flashing red 1Hz - no green or anything else. Reset does work, most of the time, in both normal and legacy modes.


  1. These may be consumer imps - they don’t have developer edition printed on them. Do these behave any differently?
  2. When is blinkup active? How many seconds should I wait after power up? I’m powering down after each attempt, in case that is required.
  3. Do you have to reset before a new configuration attempt? I’m doing that, anyway.
  4. According to the blinkup troubleshooting guide, flashing red means it’s trying to re-connect. But it never connected in the first place, so what does this mean?

Thanks in advance for any helpful comments.


They are all developer Imps.

Blink-Up is active while the LED is blinking, and by defailt that is for 60 seconds after you turn it on, unless you program it differently.

You do not have to reset.

Watch the Imp carefully while you blink up. Flashing on the Imp should stop when the phone starts flashing, and then resume. A green blink means it correctly received information.

Try covering the Imp with your thumb and finger while blinking up so that ambient light doesn’t saturate the phototransistor.

Be certain that you typed your information into the Blink-Up app correctly.

Thanks Joel - I really appreciate your comments. It’s good to know that consumer vs. developer doesn’t affect anything, for instance.

Next question - were there different blink patterns in the past? The official blinkup troubleshooting guide seems to suggest that I should be getting several (at least three) green blinks to after a successful blinkup. Whereas the old commissioning page says just a single green flash happens as the blinkup finishes, followed by network connection attempts. Your comment seems to say the same thing.

I’m getting a single brief green flash, followed by two long red, one short red, then continuous long red flashes. I’m now working on the assumption that the blinkup has worked. but it can’t connect to the network. I’m on channel 7, 2.4GHz, no firewalling of outgoing ports that I know of.

*** SOLVED ***

After figuring out it was likely to be a network connection problem, I set up a wifi hotspot on my phone and blinked that config to one of my imps. It connected! So then I started changing settings on my main wifi router to see if I could make it work.

My router is a Linksys WAG200G. It was set to WPA2 Mixed (TKIP + AES), and as soon as I changed it to WPA, the imp connected. The odd thing is that I then changed the router back to WPA2 Mixed, and the imp still connected. Even odder, when I switched on my second imp, it connected (to WPA2 Mixed) too! I think this suggests that the problem lay with the router, and resetting the security setting fixed it. It would have been interesting to see if simply restarting the router would have done the trick.

So, for any who find this post in the future, here’s the gist:

  1. Blinkup problems:

    • Do this in a dark room - the official advice to do this while obscuring the imp with fingers means you can’t see the LEDs.
    • Hold the imp perpendicular to the phone screen, so the little window in the narrow end (not the printed side) points towards the screen.
    • Blinkup should work within a minute of power up, no matter what state the imp is in. You don’t need to clear configuration between attempts.
    • A good blinkup results in a SINGLE FAST GREEN BLINK. The official blinkup troubleshooting guide blink pattern diagram is not helpful, because it looks like you should see several green blinks. Also the advice to cover the imp with fingers means you’re very likely to miss the green blink.
  2. Network problems:

    • If you get continuous red blinks after blinkup/powerup, try rebooting your router (let me know if this works!). Then try changing the security setting (under Wireless/Wireless security in my Linksys router) to WPA, connect your imp, and then change the router back to WPA2.

It may also mean that you had an imp with old firmware, and after you blinked up the first time, it updated and was then able to connect. There have been a LOT of updates to the firmware since many of the original Imps were manufactured.