... Green Blink


I got my IMP Breakout and Shield to evaluate the product but i'm still stuck on activation of the device.  I start with the IMP Breakout from sparkfun, populated the Jumper to USB and powered the device.  The IMP blink orange and it's normal.  I tried to program it with my android phone with no success (Motorola Milestone - Droid).  Look like an issue with the vertical refresh as the blink is not neat.  I tried my Viewsonic Tablet and it worked.  Now, the IMP Blink Green : Short then long green light.   I supposed that it's  a firmware upgrade as read on the forum and let it goes.  After an hour, I suppose it's not an upgrade...   I retried programming, Eject the card several times, reset the wifi setting and set back, program with WPS (with no success, only orange blink)...  nothing worked.  The best I get is blinking green light. 

I was enthusiast to try it out but should have read the forum before.  I'm not sure the product is quite stable and mature.  Why choosing a smartphone programming tool?  This don't seem's reliable.  Maybe an Infrared USB programmer would be a solution with a PC/Linux/Mac program?. 

Thus, I see the device on my WIFI router. The imp register an IP address and I can ping it. But, I never see anything it the planner about my device.

What Can I do?



( forgetting my initial programming issue, this look like a great product. I’m impress by the form factor and the small device! ). A potential nice feature to add on other projects if it work… )


This sounds like a router incompatibility. The imp is attempting to upgrade but is having issues resolving DNS for upgrades.electricimp.com.

What router are you using, and are you using google DNS?


Great device and service! But I am having a similar issue with each push out of FW revisions. The imp indicates that it is hung in the early part of the update by repeating the 2 quick green flashes and a pause. This has happened for rev 10 and now for rev 11. The flashing for rev 10 continued for nearly a whole day; power cycles, changing networks, trying to reload using shift key, all did not help. The imp finally seemed to successfully update but not due to anything I did. Now the imp is flashing again, likely updating to rev 11 and I have again tried all the above to no avail. It continues to flash for the second day. My mac address is 0c2a690013c9.
I’m using Chrome and the imp is appearing on my wireless lan list on the router.
Reloading gives an error of “line 0: imp offline.” Thanks for your help.

Dear Hugo,

My router is a D-LINK DGL 4500.  My DNS are the ones assigned by my ISP.  Maybe they use the Google DNS in forwarding? I don't know, I know little in networking.  I finally unplugged the device from the USB after more than a day.  Quite disappointed about this buying, the thing seems a bit too capricious to be used in serious design.  Any way to debug or reach internal logs directly?  Can I do something by reaching it to it's IP?


There will always be teething issues - the service is still in beta, hence the early access agreement for users. I apologize for any inconvenience, but this obviously doesn’t affect the majority of users otherwise we’d have found and fixed the issue much earlier!

@ronpod: yours seems to have updated fine now from what I can see; I saw a couple of failed attempts but then it managed it ok.

@odelric: I’ll email you to collect more info. We have a beta version of blinkup - soon to be released - which pretty much fixes any android incompatibilties. Not that it’ll help in this circumstance (as you’re online), but we email it on request.

Thanks Hugo,

I should have read more I didn't knew it was in Beta before buying.  My fault ;p, if I can help for this issue...  I will try to DMZ it, it's not supposed to do anything as the device initiate the communication but I don't know were to look at. I really understand few of the used protocol. 

Blinkup issue is really understandable with Android fragmentation, you can't try all the devices and somes may be really badly built. I will look on the forum for it but a section on supported devices may be good to be filled by the end used (Or an email  for us to send our tested devices). 

PlanB programmer may be useful too to open the market.

Another user who has had issues captured some packet dumps and we believe we’ve located the issue; some routers that run a DNS relay are returning stale lookups which means the imp contacts the wrong server to fetch the upgrade.

If your router has a “DNS relay” setting, try turning it off to get your imps to upgrade.

Now we know what the problem is we can address it in the next update, and we believe we should be able to put a workaround in place so that even people suffering from the issue will be able to upgrade smoothly without needing to adjust the DNS relay settings on their router.

The half-speed android version has been tested on as many devices as we could find - including a $75 tablet - so it’s a lot more robust than the current release. As I said, if you want to try this out let me know and I’ll email the APK.

Dear Hugo,

I finally got time to further test.   I found the DNS Relay option.  It was activated so I uncheck it.  I lost DNS on my computer but was able to ping so I tried the IMP.  The led code changed, I got 3 Greens followed by 12 red.  I didn't found this pattern in the led code table.  I dig to find where I can specify my DNS and added google ones.  Got the same issue that I had... then remembered that I must not use them (DUH...).  

I will try my ISP ones if I can find them or yahoo. 

I’ll be back ;p.


(Yes, i’m interested in trying the half-speed android version)

That worked! I removed the DNS Relay and forced my ISP DNS. I don’t know the difference as I had my ISP DNS but probably DNS Relay has something to do with the problem. The card then blinked several times with strange patterns to finally came back to my “double green blink of death”… but only stay as it for 10-20 sec before blackout.

I now see it in the planner and have been able to test the “Hello World” program.

Thanks for your help. Debugging theses little beast must be hell for you as so many router devices and parameters are possible! ;p.


Thanks for the confirmation that DNS relay was the problem for you. We’ve got hold of a router that’s troublesome in this way and believe we’ve fixed the issue for the next release. An issue that prevents upgrades is pretty much the most troubling one for us as it’s hard to work-around :slight_smile:

fyi, I just pushed release-13 (which isn’t the new release, but is release-11 with the DNS fix cherry-picked into it) to your imp. After it updates, you should be able to turn DNS relay back on - would appreciate any feedback you have on this.