Electric Imp Android App v 1.0 not compatible with Asus Transformer Prime

  1. Software Version: Android app - v1.0
  2. Hardware Version: any
  3. Environment:  Android app v1.0 running on Asus Transformer Prime running latest Android 4.0 update from Asus
  4. Description: Able to login to Android app and appears to run but fails to transfer network login data via BlinkUp
  5. Observed behavior - Blinking rate does not change to indicate data transfer
  6. Expected behavior - Network login
  7. Reproducibility of issue: 100% - tried dozens of times
  8. Steps to reproduce the problem. Try to configure an imp with a Transformer Prime
  9. Any other information potentially relevant to the issue:  I was able to configure the imps fine using a Google Nexus 7 running Android 4.1.  The blink rate appeared to be higher on the nexus versus the prime.  The nexus configured the imps with 100% reliability versus 100% failure on the prime using the same imps and same other hardware and software.

Thanks for the report; we’ve not tried many tablets, but the prime has a lot of pixels to turn on and off; it’s possibly dropping frames.

Jellybean with its triple buffering may well make this a lot more reliable on many Android devices.

I wonder if decreasing the max geometry you’re filling if you detect a large screen geometry would increase your frame-rate and make it more reliable in general, regardless of device screen size.  If you want to try something like that without waiting for a release cycle, drop me a beta apk and I’ll try it on my device and report back.