Cant get imp back online

I just noticed last life I had from my imp was yesterday morning…

2014-01-15 07:09:23 UTC+1: [Agent]

Haven’t been able to get it online again, nothing has changed, tried power cycle, bringing it closer to the access point, tried blinkup again, but nothing helped so far.

The blinkup mostly also fails, taking 5-10 attempts before it accept one, then fails to connect to the network afterwards.

What other way are there to do the blinkup? This is driving me insane

I finally got them back online again, but this is so annoying. When I got my first imp (a year ago tomorrow) I had problems doing the blink up, a year later it still seems to be tricky to get to work.

Couldn’t an arduino be flashed with a generated sketch that would pulse a led instead, when it fails to accept the blinkup from an android phone.

Any more detail?

  • There should be zero reason to re-blinkup with the same credentials. What was the imp doing when you said you couldn’t get it online - like, what LED codes, etc.

  • What code was the imp itself running?

  • What device are you using for blinkup, and are you covering the side of the imp? We have no known issues with blinkup on either iOS or Android devices at this point.

An arduino can’t be used as the device sending blinkup needs to talk to the imp server to get a token first.

When it went offline it was doing the slow red bliking.

It was running the code I use for my home automation where it sends something to xively and waits for a command from the agent.

I am using a HTC One to do the blinkup, some times it only get a few seconds in, then the imp does the triple red blink, but most times it get to the end, then does triple red blink. After that it goes into what looks like a long-long-short red blink.

Couldn’t there be a function to genereate the sketch for the arduino, where the token is put into it too?

(and forum seems to be hanging in this post every time it saves draft, but not in the other posts… O.o)

Slow red? There are many types of red blinking, eg long red, three short reds. What exactly is it doing?

If you can PM the imp-side code we can look for any issues there. If there’s any way it can get into an infinite loop then that could cause this behavior.

If blinkup isn’t confirmed by short green flash, then the imp didn’t get the blinkup. Are you covering the side of the imp with a thumb when you do blinkup? In un-housed devices this is necessary. Sounds like you are getting too much ambient light in by your description.

My Android phone (Motorola Razr) rarely works even in legacy mode, but the iPad works every time. Perhaps you could try blinkup using Windows. Do you have good wifi signal strength?

It is the slow red that is described as “Red | Slow” on the wiki, and it looks like 1hz as described too.

I doubt the code would could get into a loop it could not get out off, because there are not anything in it that actually loops, and not really any function besides turning a pin on and off. It is basicly just this modified to work with agent instead.

I both tried to cover the imp with my finger, black tape, and doing it at the middle of the night in a dark room.

@etotman you should not use legacy mode apart from for getting an old imp online so it can update. Legacy mode will NOT work as well as the default mode. We don’t have a Razr in our test fleet, though, but would appreciate feedback from using default blinkup mode.

@MikeyDK the codes are here … there is no 1Hz red code though. Which one is it doing? …MAC address of imp would also be useful for us to look up logs.

Looks like it could either be “BlinkUp unsuccessful” or “Attempting to reconnect”.

I got both of them working again, and looks like the reason they first lost connection was because of it not liking a wifi channel. Just went through the channels, channel 12 and 13 on my Linksys EA4500 does not show up on my imp’s.

Yes, the wifi channels problem hit me too, a few weeks back. Lots of wifi routers are set to Auto-select their channel. If it happens to go for channels 12-13, then your imp(s) will suddenly go offline. Hugo, I think you should mention this in the trouble-shooting page for the Blink-Up guide. This can affect users outside the US, if they are using the US-configured IMPs.

Good point about the Blink-Up guide. I’ll make sure that gets added during the next update.

US configured imps? I got one from adafruit and another from a danish webshop, both seems to react the same way. Any way to change that configuration?

No, I’m afraid not. I believe that all developer edition imps are US configured.

Yep, the danish webshop is very likely reselling sparkfun imps.

It would definitely be helpful if the Blinkup guide was updated to mention that channel 12 doesn’t work either. I modified my router from 13 to 12 after following the instructions. Bummer, but it’s working now.

Thanks @davidewan, that’s now updated and should reach the live site soon.

I just noticed it dropped off my wifi again and having trouble connecting again.

I have put code into the device section to to between access points and they are all available and set to a channel between 1 and 11. (they are actually on channel 2, 3, 7 and 6)

When I power it up it flashes this

It rather looks like the imp is cycling in a connect handler there (ie, in your code). At the end is it flashing red/off/orange/off? Hard to tell in the video as it’s so bright it saturates the camera.

I am not sure, I am color blind and the two colors are too close to each other for me to actually tell, I had hoped it was possible to see from the video.

If it is cycling through the handler, shouldn’t it then connect to one of them? All four I put in the device code (using the sample code from the wiki) are active and works, did a test with my netbook where I had it logging on to each of them to see if it was just a error in the accesspoint, but they are all fine.

Without some debug logging, it’s hard to tell; we recommend using a serial cable when doing offline mode debugging as it’s the best way to see what’s going on without affecting the network. See the disconnected debugging guide on the docs site.

You’d need to put some tape over the led or something to reduce the brightness (or increase the brightness of the surroundings) as otherwise the auto-exposure of the camera pretty much kills telling what color it’s flashing!