Cannot Find Documentation that Fits Green(3x) Red(2x) Blink Pattern

Imp has been working on my network without problems.

Today I had some time to work on project.

Reloaded some working code and was confused by Imp not working / logging to console.

so I’ve tried to unplug / reconfigure the imp

During blinkup, I get green flashes (3x) followed by two fast red flashes, then 3x Green again, for a little bit, before going dark.

I can successfully clear my wireless config - Imp blinks orange. I’ve triple checked my login / pw and do not believe that is the problem.

This is generally the sign of one of two things:

  • You have an error in your code. The imp boots, connects (green) then hits the error (red), then retries

  • You are blinked up with a stale token. Log out of your blinkup app, log back in again, and blinkup.

Similar issue to Jayz :


This resulted from using the “Connect using WPS” option and pressing the WPS button on the router.

I also tried many times the “Connect an Imp” using the method of entering the Network name and Password. In between times I also tried clearing down the wireless configuration which correctly resulted in flashing orange.

I’ve run the app on an iPhone in a darkened cupboard with the Imp held directly onto the screen next to the wireless router. The brightness of the iPhone is set to max. Since the clear down of wireless config seems to work OK it appears the flashing is being read correctly.

Note that all this worked fine until I needed to connect to a different wireless LAN. I’ve checked the password and SSID are correct and other devices have connected without issues.

After re-powering the Imp, red flashing “attempting to connect”, but no connection.

So I’ve tried all combinations of things I can think of. The most promising approach seems to be to use the WPS because at least this gets some green flashing during the blinkup and then the sequence mentioned above, but ultimately after the WPS times out the unit returns to flashing orange.

I’ve restarted the blinkup app to avoid a stale token problem and I’ve reverted the Imp code to the “Hello World” example to avoid code errors, although I wouldn’t have expected code errors since this was working until I changed wireless LAN.


I note from another post that the channel and wireless settings need to be valid for the Imp. The channel I am using is 13. I manually selected channel this following an issue with interference from other nearby wireless LANS and this resolved that issue but is 13 acceptable for the Imp? Thanks

I just changed my wireless channel to a value below 10 and this resolved the problem - Imp now connects correctly. Hopefully this might help someone else with a similar problem.

Yep, the “developer edition” imps are all US country code - channels 1-11 only. It’s not legal to ship a product in the US with channels 12/13/14 enabled.

If you buy commercial imps with the EU country code you get ch 1-13.

Hugo’s suggestion worked for me. I simply logged out, logged in, and re-blinked my imp. It fetched new code and I was good to go.

I also stumbled across the same problem.

I got 3xgreen and 2xred.

I have the app on my iphone. To solve it I clicked - Sign Out of Account - and then logged in again. This solved the problem.

May I suggest that this blink up code is added to the BlinkUp Guide in the documentation section.