Cannot Connect

I’am at a university using a secure Wifi login on my iphone. The Iphone can connect to Wifi just fine.
I tried the blinkup procedure and the IMP alternates between red and orange and then stops after a minute and never connects to the server/planner. What can I do? Any ideas bright or otherwise?

I recently had the same issue with a standard wifi access point. In my case it was an issue with the my router firewall blocking the outbound port that the imp uses to communicate to the cloud service port 31314.
see this thread for more


switch off the wifi on your iphone and use your 3G connection. worked for me.

@geoteck - Did suggested work-arounds by tonykynn and mezelve work or are you still experiencing connection issues?

Still cannot connect properly! I have tried on work and home network at both react similar. Sometimes after “blink up” green light flashes once, then blinks red, then blinks orange and eventually lights go out. My son analzyed router connections and it looks like it connects then drops then reconnects and finally drops out.
Please help!

I am using IOS-6 on iphone to do blinkup
IMP appears trying to connect a number of times but finally drops attempts, both at home and work. Is this defective IMP? I tried to load and RUN windows blinkup program from PC but it doesn’t run on my PC. what next

So first thing is to absolutely triple check that the SSID and password you’re sending the imp are correct. Yes, we need a “show password” button. The green blink means the info is being transmitted ok, but it not connecting is exactly what you’d see if there was a typo on the password or SSID.

It sounds silly, but I’ve seen it many times before!

I’am getting very frustrated. I have tried the IMP on two WiFi systems to no avail I have triple checked the SSIDs and password to no avail. I get a brief green blink, then alternating red and orange until timeout, but IMP never shows up in planner.
Could the Imp or breakout board be defective? What can I do?

It’s possible something is faulty, yes, but I’m not sure it would exhibit itself in this way.

I re-read the thread and you mention you are using a secure login at a university. If this is 802.1x authentication (it often is) then this will not work with the imp - we do not support enterprise wifi. An 802.1x network usually has at least 3 parameters to connect: SSID, username, password.

Are the networks you’re trying 802.1x?

This is a problem for education - I’m hoping this will be addressed!

We don’t have plans to address this in the short term; 802.1x is pretty heavy to implement. Longer term there may be an imp with more on-board resources designed for enterprise environments.

I’m with ileddigital - imp is garnering a boatload of interest from the education sector, but most colleges are tied by corporate-strength network security :frowning: Back to the drawing board…

Time to move off campus ;). But seriously, the education sector is very important to us. As a matter of fact, we will start holding electric imp workshops at universities come Jan '13 - obviously, we’ll start with local universities and expand from there. As Hugo mentioned, we are under no illusions that 802.1x support is going to be easy to implement so this is something that we’ll consider taking on when our product has matured.

I am trying to get around this (enterprise wifi on uni campus) by tethering my imp through my verizon iPad’s hotspot. However, I think there is something wrong with the character encoding of the SSID name which prevents the imp from connecting.

The SSID of the iPad becomes “Alexander’s iPad” - however even on my pc when I see this as “Alexander’s iPad”. Normally this is not a problem as most devices see the SSID and can join it, however as I’m having to type in the SSID I’m stuck. I’ve tried both versions (apostrophe and ’) but neither one works…

was able to fix this by going into the ipad’s settings and changing the name of the iPad to something without an apostrophe. I thought the “'s iPad” was an addition to the owner of the device but it is just a string in the setting above.

I am having similar issues with our company wireless (where I work and prototype). I had the IMP connect at home all fine, then since the new IDE came along, it does not connect at home and never did at work. I had IT open the firewall on 31314. No avail as I can tell so far, I am stuck. Two weeks now and still haven’t got my IMP working properly to actually have fun with it. Very frustrating. Will have to check with IT again ands see whats changed at home…