Cannot Connect to WiFi

My Boss brought back a couple of Imps from the US to the UK and asked me to evaluate them. The only way I can get my Imp to connect is by switching off all WiFi security ? Do European Imps differ from US Imps I wonder ?

US imps work over here - I have several running code right now. FWIW, my router(s) use passphrase-protected WPA/WPA2.

What is the security setting on your router, do you know?

Make sure that your wireless router is operating on channels 1-11. US/CANADIAN version of the Imp will only connect on those channels.

Sorry should have provided a few more details …

Phone is iPhone4S
Tried connecting to work router - BlinkUp appeared to work OK (Single Green blink) but then Red 1Hz flashing (attempting to connect to WiFi) and then off after a minute or so.

Tried at again home - where I have admin access to my Netgear DGN100 router. Exactly the same sequence until I disabled security.
Other modes tried were:

Disable - works !!!
Mixed WPA-PSK+WPA2-PSK - my normal setting
WPA-802.1x - Not tried or used as for corporate networks

Once connected (with no security) everything appears to works fine ? Maybe a vagary of the router ?

Hi Jwehr,

Your post arrived as I was replying to smittytone !

Sadly I cannot configure my router to US but do have ‘Canada’ as a region so will try that tomorrow !

Other availabe regions are:
New Zealand
South America

The region determines which Wi-Fi channels your device (router, imp, whatever) has access to. US imps (by law) can only use channels 1-11. But I’d expect an imp not to connect at all to a UK router on channels 12 or 13, not to connect and then drop as yours appears to be doing. Indeed, the fact you can connect with security disabled suggests your router is already on a suitable channel.

It’s hard to know what to suggest. I have had problems connecting Macs and iPhones to certain routers which don’t like Mac/iPhone-set WPA passwords, but I assume your iPhone connects to the router, so we can probably discount that. IU would try it with a plain-English WPA2 password, in any case.

A couple of other things to try: double-check your WPA2 password has been stored by the BlinkUp app, ie. you’ve set ‘Remember Password’.

Alternatively, try using WPS, which both the BlinkUp app and your router support. The WPS PIN is on the back of the router, IIRC

Here is the user manual:

On page 38 it shows the Setup - Wireless settings config and it looks like you can set the region. If you can set it to US, do that. If not, change the Channel from auto to something between 1-11.

Double check that you’re not trying to connect to a 5GHz network, which the imp can’t see. An iPhone4S can’t connect to 5GHz though, so that’s a little unlikely I suppose, if the phone will connect to the network.

Now Working on Mixed WPA-PSK+WPA2-PSK !!! and others

So starting methodically from scratch I logged into my router, changed the security setting and re-entered password - THEN re-booted router. (Previously just clicked ‘Apply’)

Removed existing WiFi connection to iPhone, power cycled (Off/On) iPhone and then re-joined it to my WiFi network

Then powered and Blinked Up my Imp from iPhone (remembering to Save Password). Then power cycled my Imp and lo and behold it then correctly joined the network and became visible in the IDE !!.

Tried this for other security setting settings using same routine and all OK !!
Perhaps a ‘funny’ with my router ? Next step is to re-try connecting to my work WiFi next week.

Thanks for all your help !!

No problems, Mike. I’m glad you got it working.