Cannot connect to Airport Express


I can create a hotspot on my mobile (iPhone 4S), and the Imp can successfully connect after BlinkUp. But no matter what I try, I can’t get the Imp to connect to my normal WiFi.

I’m using an Airport Express (2012/Apple Tv model). I’ve tried separating the 2,4 and 5 GHz SSIDs, tried using guest network capability, no encryption. Now i’ve run out of ideas. Does anyone have any hints on what to try next ?


Hmm, what exactly happens? Anything strange with the SSID or password (non-ascii characters?). Does the imp blink red-orange-off or orange-red-off?

We use older airport expresses extensively, and our office AP is a latest-generation Airport Extreme.

It receives the configuration via BlinkUp and then just blinks red slowly.

The SSID is only upper and lower case chars, thats the same on both iPhone and Airport, so that shouldn’t be the problem. I just tried using the same password from my Airport Express on my iPhone, and the Imp connected successfully, so that can’t be the problem either. My password includes upper case, lower case, numbers and signs, but only standard ascii chars.

I get entries like this in the log on the Airport Express:
Apr 10 13:19:01 Severity:5 Connection accepted from [fe80::7aca:39ff:feb4:30f4%bridge0]:51837.

Are you sure it’s getting the blinkup? (ie, do you get the green flash just as the blinkup finishes?). Slow red mean “I can’t find the configured SSID” - it can’t find it to join, hence can’t get any further.

That log message isn’t anything to do with the imp I’m afraid.

Yes, it blinks green once right at the end.

And you’re definitely broadcasting a 2.4GHz network?

Yes, the radio mode is set to “802.11n only (5GHz) - 802.11b/g/n”. Not that i’m entirely sure I know what that means, but my iPhone can connect, and as it is a 4S, it can only do 2,4 GHz. My next step will be to try the different radio modes of the Airport Express, but I properly won’t have time for that until next week.

Sounds like that means it’s 11n only at 5GHz and 11b/g/n at 2.4, which as you say should work fine with the imp.

Oh, one thought. What channel is your 2.4GHz on? If you’re using a US-spec imp (eg from sparkfun) it’s channels 1-11 only, so if your AP is set to ch12 or ch13, you’d see exactly this behavior.

Doh, I hadn’t considered that. Even though i bought it in Denmark, the company i bought it from is the national reseller for Sparkfun. I changed channel from 13 to 11 and now it works.

Thank you.

Yeah, I’d not considered it either! Sorry, that should really be a FAQ. When we have more EU distributors then they would be selling EU spec cards, which have the extra channels.