Blinkup problems with WPA and WPA2

Got two Imps with Sparkfun Imp Breakout boards today for classroom experimentation.
I tried for a couple of hours to get the Android Blinkup app to work on three different phones but got red lights every time.
I switched the “WPA and WPA2” encryption off in my Netgear FVS318 router and selected encryption “None”. Blinkup appeared to be successful for a while but then goes back to blinking orange. The device showed up briefly on the IDE but is gone again now. This is not as straightforward as I had hoped.

Router: Netgear FVS318.
Region: United States (only option on this firmware)
Current Channel No: 11 - 2.462GHz
Mode: b & g
WPA with PSK
Encryption: TKIP+AES
Password is correct.
The Imp is about 7m away from the router with only a ceiling in between.

Any ideas why I have trouble with WPA?
Are others having reliability problems?

Thanks, Hugo.
Board still seems to work OK still with WiFi encryption set to “None”. I get blinking green light and the sample LED blink program runs.

If I switch to WPA with PSK, Encryption: TKIP+AES, I get blinking red LED on Imp.

Imp: 0c2a6904f750
Imp breakout: 234666ab5ba5ceee

I’ll try the other breakout board later but I think the one I’m using is OK.

Don’t think it’s a WPA issue. If it was successful but then went back to flashing orange, the most likely thing is that your sparkfun breakout has a soldering issue or bad ATSHA, so the server is telling your imp to go away.

If you can give me the mac address of your imp then I can check that is indeed what is happening. Tried the other breakout board?

I can see successful connects, are you running with security off at the moment?

Are you setting WPA2 or WPA? Both should work (AES, TKIP+AES are fine).

It sounds a bit like the blinkup has not worked when you did it with the password, but did when you did without password, hence it’s still trying to connect without a password and failing. At the end of blinkup, the LED should flash green briefly to indicate the blinkup was received successfully (irrespective of whether the credentials were correct - it’s just indicating that it got the transfer ok). Do you see this?

Hugo, I’ve succeeded in getting both configured. I may have caused a problem by using the same Blinkup for WiFi with and without security. i.e., When I turn security on again in my router I should

  1. disconnect WiFi on the phone and reconnect.
  2. on Blinkup, select the WiFi again and enter the password. (Am I right in thinking that this will generate a different Blinkup code than that generated when the phone first connects up without security?)
  3. optionally clear the WiFi settings from the Imp.
  4. Blinkup.

For anyone else having trouble try this sequence. If you suspect that it hasn’t ever connected to the web server then the Imp may be running old firmware. Enable ‘Legacy Blinkup Mode’. Once you connect the firmware will be updated.

  1. Power up the Imp. If you get the flashing orange code then skip to step 3 as the Imp is not programmed so you don't have to clear it.
  2. Optional: clear the Imp configuration using Blinkup.
  3. Disconnect your phone from WiFi and reconnect.
  4. Start the Blinkup app, log in, select the WiFi and enter the password.
  5. Send Blinkup.

The comment preview shows this in all caps. I hope it doesn’t on submit!

What network your phone is connected to should be immaterial; nothing is sent between the phone and the imp on wifi (try turning off wifi altogether and blinking up - it’ll still work).

What may have been confusing you is that any stored settings in the blinkup app show “blobs” as the password, meaning you can’t tell if there was a password saved (or even how long it was).