Blinkup not working with Galaxy S III

  1. Software Version: App V 1.01, Android Version 4.04
  2. Hardware Version: April
  3. Environment:  Samsung Galaxy S III, TP-LINK router, WPA2-PSK security, Password has no special characters 
  4. Description: 
  • The SD card is blinking red before starting up the Blinkup
  • During Blinkup, no LED blinking is observed on the card
  • After Blinkup, there is some delay before the card starts blinking red again. 
  • I also noticed the LED blink green momentarily before it starts blinking red again but not been able to reproduce this behavior always 
  • Expected behavior : Normal Blinkup Routine
  • Reproducibility of issue: Always
  • Steps to reproduce the problem. Refer Description 
  • Any other information potentially relevant to the issue: I also checked my DHCP client list on my router, no instance of the imp and monitored tcp port 31314, no packets 
  • Thanks for the very detailed report.  We’ve experienced positive results with the Samsung Galaxy SIII but results can still vary.  That you experienced a green blink means that network connection was successfully established but lost.  It could be a router compatibility issue and we are looking into this at the moment.

    Thanks!

    Nong

    Can you reboot your router and see if it helps?

    …and also try killing all non-essential tasks on the SIII? Anything can cause the phone to drop frames, despite having a hugely powerful multicore processor :frowning:


    We have an improved android app in the works - which takes twice as long to send the data - but is more resilient to dropped frames than the current one. Problem is, the support for receiving the slower data rate is in a software update and hence your imp needs to be online to get it.

    I am using S III, it only had problems with WPS, when normal password is used, it worked fine.

    All,


    I was finally able to commission my imp successfully ! :slight_smile:

    I suspect an incompatibility with the router and/or a firewall. But I have been able to connect to the router in the past with other wifi modules. Also, an intermediate LED code where the device is connected to the router and not the internet yet might be useful. 

    There is an issue in release-2 where a WPA2-MIXED network is identified as WPA2-TKIP in some circumstances; this is fixed in release-3 (out soon!)


    Also, there is a new flash code: yellow then red indicates DHCP OK, trying to connect to server (this is the state after red then yellow, which is attempting to DHCP).

    With the new imp firmware updated over the weekend, imp blink works with my S3 on normal user/pass network connection, WPS connection, hotspot on S3 (FoxFi).
    Only problem I had with blink up is after the imp is stable (either connected or not) it does not like to accept blink up. I have tried to cycle power to imp, and then quickly blink it up, it worked for me every time.

    Hmm. I wonder if this issue is actually that the active hotspot on the SIII is making the blinkup more unreliable (as it’s more load)? You’re running the hotspot on the same phone that’s doing the blinkup, right?


    The blink behaves the same on fix router as well as hotspot, so I don’t think it is the S3. Yes, I am running the hotspot on the same phone.