BlinkUp no longer working

I had posted in the discussion ‘STUCK AT “NO WIFI SETTINGS”’, but feel it deserves to get renewed attention. I can no longer blink up with my iPhone. I had thought it was due to a new breakout board, but alas, I’ve tried a couple of different boards with the same result. I recently updated my iPhone to iOS 8 and I believe that’s the culprit, as I just tried BlinkUp with an iPad on iOS 7 and it worked the first time several times – all conditions the same. I can successfully clear the wireless configuration with my iPhone, but can NOT effect a BlinkUp.

Hi ctmorrisonhvacsp,

We havent seen any iOS8 specific errors but are happy to look into it. What iPhone version do you have?


I have an iPhone 5S with iOS 8.0 and have 2GB of free space. I have used this same phone numerous times to blink up about a dozen devices multiple times each.

In BlinkUp, I have seven WiFi networks listed (in case the number of networks causes an issue).

FWIW, I’m in the process of upgrading the iPad to iOS 8.0 to see if it experiences any issues. I’m wondering how many EI users jumped on iOS 8.0. I usually wait for a “.1” release, but was eager to see what was new.

I was on the iOS beta for a couple of months on my 5S without seeing any blinkup issues (ditto for the GM release for a week before my iPhone 6 arrived). We’ve confirmed no issues with iOS8 on 5, 5c, 5s, 6 but are checking for someone with a 4S who has upgraded - I know we initially had some strangeness with iphone 4’s when iOS7 came out.

Blinkup can’t scan for wifi networks - it can only pull the current SSID from iOS.

I guess the usual try quitting the app (task switcher, throw the app off the screen) and power off/power on is worth trying for you. I never needed to do this myself but maybe something is strange with your upgrade.

First bit of data: the iPad with iOS 8.0 was able to BlinkUp just fine. I deleted the BlinkUp app from my iPhone 5S and reinstalled it, without any benefit.

After several failed attempts with my iPhone, the iPad had no problem. Hmmm…

(updated) I simply might not be aware of the orientation of the photo diode on the P3V3 board. I tried twice with my phone in a slightly different orientation (about a 45 degree angle along the edge with the USB connector and it has worked 2x successfully. Odd, I’ve done it the same way for months without issue. I’ve “assumed” the photo diode faced upwards from the face of the board with all the components. I’ve always had my iPhone (and in fact the iPad) parallel to the board.

So…just tried another iPhone 5S and had trouble, but eventually had success. This iPhone is on iOS 8.0. I continue to believe there’s an issue with BlinkUp that’s likely related to iOS 8 (perhaps in conjunction with 30.15). Recall–I was having no issues until about a week ago – before I upgraded to iOS 8.0. The light level of the iPad may be different than the iPhone 5S. I tried it with another iPhone 5S on iOS 8.0 and had no problem with multiple BlinkUps. Any thoughts on settings in iOS that may impact BlinkUp?

Right now, the only way I can do a BlinkUp with my iPhone on the P3V3 is to put it at an angle along the edge with the USB connector – even in a nearly totally dark room. This used to work in normal room lighting when it was parallel to the board. I seldom had a failed BlinkUp.

The imp obviously detects an attempt at a BlinkUp, as the LED stops blinking. Any chance for some new flashing code that would indicate poor BlinkUp light contrast if that’s the issue. I really hate to waste anyone’s time on this, but if I’m having trouble after months of imp usage, I would think others would have bad experiences, too.

My phone has no trouble clearing the wifi configuration.

(updated) Just powered up an imp001 in an April board. Cleared the configuration without issue. Cannot BlinkUp. This is really getting frustrating! If I were new to EI, I’d likely be dismissing it as not ready for prime time. As it stands, I can’t deploy any more devices until this is resolved–can’t get past blinking amber.

In iOS 8 Settings (likely 7.x, too), there’s an Electric Imp setting “Use Cellular Data”. I remember looking at this setting recently and may have changed it from OFF to ON, perhaps thinking this would help me when I’m on a rooftop trying to BlinkUp. Evidently, this was not sound thinking. What’s this setting for? It may be wise to update the app to either remove this setting if using it creates problems or explain undesirable side effects for dummies like me who don’t know what they’re doing.

I have changed it to OFF and I seem to be able to BlinkUp once again. That being said, it still seems that I need to clear wifi settings more often than before and often seem to need to cycle the power on the imp in order for a BlinkUp to work. I always make sure the LED is blinking when I attempt a BlinkUp. For the past couple of days, it has been the continuous amber blinking.

(update) Took my device home to test the above concept on my home WiFi. Can’t BlinkUp. Damn! I tried my iPad with iOS 8 – no problem. So, what makes one device OK and other not? I’ve done nothing “special” to my iPhone (ex not jailbroken). This is getting frustrating! I did notice the “Use Cellular Data” is not present on my iPad which may make sense since it’s a WiFi only device.

Sorry for all the difficulties you’ve been having!

I’m not certain what could be causing this - and it’s unfortunately very difficult to debug / dig into without hardware that we can reproduce the conditions with.

It sounds like this is isolated to a particular phone of yours - I would recommend the following if you haven’t already:

  1. check screen brightness and set it to max

  2. Restart your phone (I know I very rarely powercycle my phone)

  3. logout and then back into the app

  4. uninstall and reinstall the app

I’m not sure if 2-4 will help, but it probably can’t hurt to try.

I am not an iOS developer, but I believe that Apple requires any app that communicates with the Internet to include that setting. Since the Electric Imp app requires you to sign in (which makes a web request to our server) it has be included.

It shouldn’t make a difference unless you are logging in/out.

Thanks @beardedinventor for your thoughts. I kinda feel left out in the cold on this one. I also understand how difficult it is to help when you don’t have access to the device and don’t see this elsewhere.

I’m currently doing a factory restore on my iPhone followed by restoring from a backup. Don’t know if this is the best way to get a clean iPhone (as opposed to a factory restore and manually setting it up, again). I’ll do some tests afterwards and report my findings.

I have no screen protector on the phone and don’t recall doing anything at all out of the norm. It’s just been very frustrating and a huge waste of time. The fact that is seems to have started about the time I did the install of iOS 8 makes me think it’s related. However, I have other devices on iOS 8 and they’re OK.

Hugo had mentioned to me a long time ago that the app automatically uses the maximum brightness on an iPhone. That being said, it is set to the highest setting and having auto brightness on/off seems to make no difference.

OK. Initial feedback based upon clearing wifi configuration on an imp001 and two imp002 (P3V3 and C3V0+), the factory reset followed by a restore from backup seems to have solved the problem. However, past experience has shown promise only to be followed by more problems.

On a related note, during this excessive testing, I have noticed that too often during a BlinkUp, I’ve received notifications from Mail, Messages and/or Phone that stops the BlinkUp mid-stream. Are there best practices about turning off Notifications to avoid mid-BlinkUp problems.

Still having some issues. It almost seems like I need to re-enter the WiFi password in the app in order for it to work. Even that doesn’t work all the time. However, I seem to have a greater frequency of success now.

Very strange indeed. Yes, getting notifications mid-blinkup is not good, but I don’t believe we can do anything from an app point of view to prevent this happening.

“Use cellular data” is just a setting which, if off, will prevent the app in question from using the cellular network if there’s no wifi. If you turn that off and don’t have wifi, then the imp app won’t be able to talk to the imp servers, which could be problematic.

Screen protectors etc really make no difference. All I can think of it this is an ambient light issue given these are unhoused devboards - the iPad being bigger is maybe blocking out more ambient light?

Still having issues with my iPhone 5S. I cannot successfully BlinkUp any longer in spite of all the “tricks” I try. Every other device I try seems to work fine. It appears I may need to purchase another device just for BlinkUps, but I don’t want to spend or carry more than needed. Will BlinkUp work on an iPad Nano or is it likely too vulnerable to ambient light issues due to the small screen size? I don’t want to be “penny wise and pound foolish”.

(update) Before I throw in the towel, I’m going to do a Factory Reset and manually set up the iPhone rather than restore from a backup. I’m hoping there’s some obscure setting that’s getting restored that’s causing my issues.

(update) Just did a factory restore. The first and only app I installed was BlinkUp. I successfully Blinkup’d 3 devices (imp001 and 2 imp002s). I’m going to do the minimal setup on the iPhone (email, etc.) and then see how it works. I’ll then progress very slowly with other apps. What I can report is that installing BlinkUp on the “fresh” system took far longer than when I deleted the app and re-installed it on the existing system. I’m a bit curious as to why it took so much longer. It’s almost as if deleting the app may not completely clear it out of memory (along with settings?).

I’m guessing this is not really a viable option, but sending the iPhone to us so we could attempt to replicate the issue would be rather useful (as we have not been able to replicate any problems with any iOS8 device here, including the 5S).

If it is doing something strange, we could capture the output and then in theory replicate and fix the issue.

The nano doesn’t run iOS so that’s not going to work for you I’m afraid.

As I asked before - what’s the environment for the blinkup? The board is unhoused, but how much light is there? Is the phototransistor likely to pick up light from other sources than the screen? etc

btw clear wifi settings should do absolutely nothing to help with blinkup. A blinkup replaces ALL the wifi settings hence clear+blinkup is identical to blinkup.

The only difference is that if the blinkup fails (and the imp already had settings) then it’s easier to spot as the imp will still be flashing amber.

I apologize for missing your inquiry. In general, I’m holding the boards in my hand in normal office lighting. On the imp001, I cover the side of the card with my thumb. I have tried covering the device with a towel to block out light, but that did not help. I’ve also tried with all the lights off without success.

In all cases, when my iPhone would not work, all of the other devices would BlinkUp in the exact same location/orientation/lighting/etc.

Good to know about clearing settings. That suggestion had been made by another very experienced used, so I thought it was worth a try – supposedly for “stubborn settings”.

Our messages are a bit out of sync, as I’ve doing taking some action while posting. As of now, the problem seems to have gone away with the factory reset and manual configuration (as opposed to restoring from a backup). There may be some setting that caused the problem. I’ll be testing more and report findings.

I cannot live without my iPhone – a sad statement, perhaps, but it’s almost like an appendage. Therefore, I cannot send it to you folks if the problem persists.

Very interesting that a clean config on the phone results in everything working. Were you using any accessibility features? (zoom, greyscale, increase contrast, etc)

No accessibility features. Just a factory restore followed by configuring iCloud and adding two email accounts made it work – for a while. It’s not working, again, and the only further changes I made was to install a GPS app I’ve been using for two years and “Units Plus” a conversion tool I’ve been using for months–neither one launched.

I’m back where I was–can’t BlinkUp with my phone but can with another in the same location, orientation, etc.

Giving up for now–just too frustrating.

If you quit the other apps (ie task switcher and then throw them off the screen) does it start working again? (though, I guess not launched implies they can’t be running - I don’t think installed apps can auto-run).

Does this happen with every unit you try?

We’re really very interested in fixing this problem, but replication appears to be the hardest bit for us :frowning:

Yes, it’s the same with every unit.

Hmmm…quit all apps (the only ones running were: Mail, Messages, iPhoto, Find Friends, Electric Imp, Phone, ?). Powered off the iPhone. Restarted iPhone. Launched Electric Imp. BlinkUp successful. Cleared Wireless Configuration. BlinkUp successful. Cleared Wireless Configuration. BlinkUp failed. BlinkUp successful. Cleared Wireless Configuration. BlinkUp failed. BlinkUp failed. BlinkUp successful. Cleared Wireless Configuration. BlinkUp failed. BlinkUp failed. BlinkUp failed. BlinkUp failed.

Powered iPhone off and on. Launched Electric Imp. BlinkUp failed. BlinkUp failed.

Powered iPhone off and on. Launched Electric Imp. Cycled power on imp001. BlinkUp failed. BlinkUp failed.

Are you as tired as I am about this? :wink: