Blinkup failure, no flashing

I decided to break out my Imp that I purchased awhile back (Model IMP001). I had the thing connected before, but now I can’t get the thing connected no matter how many times I try blinking it up.

  1. On start, it flashes red.
  2. I start the blink up and it stops flashing
  3. Blink up finishes and the imp continues to not flash

Thats it. I let it sit and it does nothing. I reboot it and I am right back at step 1. No red or green confirmation from it. It doesn’t appear on my network or in the IDE. I have verified WI-FI settings multiple times and followed the blink up troubleshooting guide. I also tried the legacy blink up mode just in case.


Try another phone or tablet for blink-up, if another environment (like a dark room) fails.
Sometimes it is hard to blink it up. For me the same. Sometimes it costs me half a day.
Have you installed the latest blink-up app? This has also a legacy mode (Android), which you can try.
Also make sure that your WiFi channel has been set below 12

Yup. I tried it with an IPhone 5 and blink up took right away. I suppose it would be helpful if they added a list of compatible devices to the troubleshoot guide. I was trying a Samsung Galaxy Rugby Pro. Thanks.

You may have more luck with the Samsung if you disable power save mode (and adaptive screen thingy if you have that option too). Release 27 is happier with android, and it’s due very soon.