Blink up worked but device in not working


I have two units that are experiencing the same problem. The blink up went through as I can see the devices in my online control panel. However, when applying power to the devices they start to blink Red-Amber-Off a few times and then blinks green once quickly, then leds stay off for a few seconds and the process with the Leds restarts?

What is happening?

Got the mac addresses? Sounds a bit like they are trying to update but not managing to.


Hello, these devices are still not working???

So, I don’t see 0c2a6909388b at all in the last month.
0c2a69093932 has connected and been told to get an upgrade, but it never fetches it - instead it just comes back and is told to upgrade again.

Are you blocking http at all (upgrades are fetched by http)?
Can you try on another network to see if they upgrade at that point?

Hello, I double checked the 0c2a6909388b as what it reads from the label. I see the device in my online control panel as the device ID reads 20000c2a6909388b. Both of them are saying the same, [Status] firmware update triggered.

This is not a network thing as I have two other units that work perfectly on the same network. I think it may be an IMP problem. If that is the case, what do I do as they are already soldered onto my pcbs???

I need to get these working as a 50% failure rate is not acceptable. Can these units be replaced?

Hugo, I need help on what to do??

Okay, I got it as they are working now (was a hardware problem)… All four of them are working…However, in the future what if they really don’t work and it’s an IMP problem, what is the policy? Do I return them, etc even though they are soldered onto the PCB?


You’d need to desolder them and send them back, but failures are pretty rare - there’s not actually a huge amount to go wrong if they’re not exposed to adverse electrical conditions.