Android app 1.0.1 now available

This one has some tweaks to improve BlinkUp stability; if you’ve had issues with 1.0.0, please give this one a try and let us know in this thread how it’s working for you - including details of the phone and OS version.

I just updated to BlinkUp 1.0.1 and it works great with my HTC Evo, Android 2.3.3.

Still no joy on the Samsung galaxy Y.   Never gets the sync sequence.

Consider adding a “Show password” checkbox?  I spent 10min trying to configure my Imp, wondering why it wont connect, only to re-enter my password and it worked just fine.  The default Android (maybe iOS too) wifi password input has a “show password” box.  Obvoisly, default to unchecked by default.



Not working with Samsung Galaxy Mini either - I guess I have to wait the iphone app or try to get a HTC which seems to work better.

As a desperate action even started the IMP APK on Google’s Android Emulator (on Windows). It’s not working, the transmission takes two-three times more than on phone so I suppose the bit length is totally screwed up because of the slowness of the emulator.

Worked using a Motorolla Xoom, but I had to the following…

Rebooted Xoom, hold card at a 45deg angle downward, directly on the screen, and with my thumb covering the top… Worked perfectly after that for both cards.

Straight on it would fail every time at any distance (Tried 30+ times with 2 cards).

release-4 has some thresholding improvements which should help improve reliability here too. All our tests are with the phone flat against the end of the imp, as this is all you can do with it in a socket :slight_smile:

I’ve been having problems with my Samsung S4, I tried for around an hour, trying both normal and legacy with no result, only made the red blink faster for a couple of seconds. Went back to it when daylight had gone and the room was quite dark, it then worked (with legacy selected). I usually had no issues with my iPhone…

We’ve not had issues with S4’s here - was the imp you were using recently connected, or is it one that was fresh out of the box? The older imps only support legacy mode, new ones are fine with tristate, which is a lot more reliable with Android phones.

iPhones rock as far as frame rates are concerned…

I’m guessing this has been previously discussed, but if your struggling with the Android App has consideration been given to using the photo flash Led as the source of the blink up? (I’m thinking it’s going to be a show stopper for me if blinkup can’t be reliable on Android) probably a reason why not possible but thought I’d mention it in case.

Photo flash LEDs can’t generally be controlled through the APIs accurately. Blinkup relies on openGL to render frames which is at least designed to give a consistent frame rate (even though it rarely does on android).

Not working with Samsung SGH-S730H, Android version 4.0.4

I used to install my imp iPad.