After FW update blink pattern: short red, off, long amber, off (SOLVED)

My IMP001 with device nr 23185feb6e4936ee does not connect to wifi after firmware update was triggered. I tried powering from USB and battery (plus 1000uF capacitor). Wifi coverage is good. Wifi credentials are checked. The IMP is blinking in the folowing way: short red, off, long amber, off.

I’m having the same issue, any update?

It sounds similar to what I experienced yesterday. A Blink-up solved my dilemma.

That worked on one of mine in the log it had this,
2014-08-28 08:23:30 UTC-6 [Status] firmware update triggered
2014-08-28 09:06:21 UTC-6 [Status] Downloading new code; 52.84% program storage used

On the one that didn’t work I have this in the log
2014-08-28 08:16:02 UTC-6 [Status] firmware update triggered
2014-08-28 08:16:03 UTC-6 [Status] firmware update triggered

I do recall seeing something like “firmware update completed” on some of my devices. For others, it was simply the “firmware update triggered” and then back to normal.

red/off/orange/off is “connecting to server” (see ). This is generally seen after the device has joined the network, got an address, and done the DNS lookup.

Generally this is seen if the device cannot connect to the server on port 31314.

From the logs, I can see that it successfully upgraded, but didn’t get back to the server. Could you re-blinkup and see if it comes online?

I have not had any luck after re-blinking up. I have 4 devices I’m working with (all are imp002 all on same network). The only device that works is a board that was blinked up yesterday for the first time. It is working correctly. I have three other boards that worked previously, they all seem to have stopped after the update with one exception. One board was working yesterday after the update but today is not, now all three are blinking Red/off/Amber/Off other than the working one. I have updated the latest Blinkup App, and re-blinked them up, I have tried two different Wifi networks, both of these networks work with the working Imp. I tried to delete one device in the ide and then re-blink it up, and it also flashes Red/off/Amber/Off, I’m not sure what to try next.

I tried to re-blinkup (after clearing wireless config), but no success.

@jrsikken @enyeartC could you email dev-team with more details on your setup, eg:

  • what router you are using
  • what code you’re running (are you doing server.connect() in your code or letting the OS do the connect?)
  • (not that this should work, but…) have you tried clear config, power cycle, then re-blinkup?

Actually, I think we’ve worked this one out now. If you power it up, you should see it connect. It had a stale list of servers and was giving up before it got to the end of it, so we’ve tweaked some DNS to fix that immediately.

Ok thanks for the help. I thought I was going crazy since it just started working again after the clear config, power cycle, then re-blinkup I just did. All are working now.

Yes, my imp connects. Thanks!